Bug 294891 - libgettextpo should be part of gettext package not gettext-devel
libgettextpo should be part of gettext package not gettext-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gettext (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-18 11:28 EDT by Dwayne Bailey
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-21 01:16:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dwayne Bailey 2007-09-18 11:28:18 EDT
Description of problem:
In order to use the libgettextpo library (which allows a program to read and
write Gettext PO files) you need to install gettext-devel.  More user orientated
applications are beginning to use this library to work with PO files thus it
doesn't make sense to force them to install the -devel package.

Version-Release number of selected component (if applicable):
gettext-devel-0.16.1-8.fc7

Expected results:
Simply install gettext without gettext-devel and it will install libgettextpo.so

Additional info:
On Mandrake I notice that they break the Gettext package up into base, libraries
and then a separate gettext pacakage.  This may be an option to reduce the
install requirements of the full gettext environment but only the NLS requirements.
Comment 1 Jens Petersen 2007-09-21 01:16:42 EDT
Ok, I'm adding a gettext-libs subpackage in 0.16.1-12.fc8.

Unless it is causing big pain, I probably won't do an F7 update for now.

It is late in the F8 development cycle now, so I'll leave any major
restructuring for F9.  If you could file a separate bug about that it
would be helpful. :)
Comment 2 Dwayne Bailey 2007-09-21 08:05:10 EDT
(In reply to comment #1)
> Ok, I'm adding a gettext-libs subpackage in 0.16.1-12.fc8.

Fantastic

> Unless it is causing big pain, I probably won't do an F7 update for now.

It can be worked around in F7 so it is not major pain, so I see no need to
implement this for F7.

> It is late in the F8 development cycle now, so I'll leave any major
> restructuring for F9.  If you could file a separate bug about that it
> would be helpful. :)

Will do and will give the bug number here.
Comment 3 Jens Petersen 2007-09-21 08:09:31 EDT
Okay cool, thanks. :)

If you see any problems please reopen this bug too.
Comment 4 Dwayne Bailey 2007-09-21 08:15:25 EDT
(In reply to comment #1)
> It is late in the F8 development cycle now, so I'll leave any major
> restructuring for F9.  If you could file a separate bug about that it
> would be helpful. :)

See Bug #300161

Note You need to log in before you can comment on or make changes to this bug.