Bug 29496 - Installer left a dead system
Installer left a dead system
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Erik Troan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-25 20:45 EST by Suhaib Siddiqi
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-27 12:16:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suhaib Siddiqi 2001-02-25 20:45:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


When performaing upgrade from RH 7.0 to Wolverine RC1, Installer hanged 
at "Performing post Installation task"
Leaving the system dead.  Since it did not get to making boot floppy, the 
system is unbootable

Reproducible: Didn't try
Steps to Reproduce:
1. Cannot reporduce, except to do a fresh install :-(
2.
3.
	

Actual Results:  When performaing upgrade from RH 7.0 to Wolverine RC1, 
Installer hanged at "Performing post Installation task"
Leaving the system dead.  Since it did not get to making boot floppy, the 
system is unbootable

SYSTEM NON FUNCTIONAL

Expected Results:  Supposed to install properly, is not it? Or what should 
i expect when I geta  dead system?
Comment 1 Suhaib Siddiqi 2001-02-25 20:50:26 EST
Hardware info:

HP Pavilion 1G (100 Mhz) PIII, Soundblaster Live, 128 MB RAM, GeForce2 Ultra 64 
MB video RAM, initio ultra-wide SCSI card.
Comment 2 Michael Fulbright 2001-02-25 23:10:52 EST
If you switch to VC3 and VC4 (cntl-alt-f3 and -f4) what are the last few lines
on each screen?
Comment 3 Suhaib Siddiqi 2001-02-26 07:26:50 EST
I was too tired therefore did not investigated further.  I plan to
dig out the cause of failure, today or tomorrow.
What I assume, from watching the screen during upgrade, is that
installer was installing, all the possible kernels

kernel-smp-4.2.1
kernel-pcmia-4.2.1
kernel-BOOT-4.2.1
kernel-4.2.1

Do not ask me why installer came to the idea of dumping all the kernel's rpms
on my hard disk?  It is not a smp machine and I had only one kernel installed
on it, which was kernel-2.x from RH 7.0.  I think during Post Installation Task
installer got confused and could not figure out which kernel to configure
for this machine thus hanged. 

This observation is only from watching the screen during upgrade... I will 
investigate more.
Comment 4 Glen Foster 2001-02-26 18:51:59 EST
We (Red Hat) should really try to resolve this before next release.
Comment 5 Suhaib Siddiqi 2001-02-26 21:16:24 EST
OK, diged into the problem. Booted with Disk1 when I got to "choose your
language
used crtl+alt+f2 to get to shell, mounted hard disk partition to /...

  The actual cause of failure was that
/etc/lilo.conf had bogus entries in it:

image=/boot/vmlinuz-2.4.1-0.1.9
	label=linux
	initrd=/boot/initrd-2.4.1-0.1.9smp.img
	read-only
	root=/dev/sda1
	append="hdd=ide-scsi"

I have no idea why "smp" was inserted into initrd=.....?

The default= had no "linux" after it... in fact it was only "default="

After I edited /etc/lilo.conf, ran e2fsck then /sbin/lilo -v, reboot and system
came up :-)

I had to run rpm -e kernel-smp and rpm -e kernel-BOOT to get rid of extra
kernels installed.

Suhaib
Comment 6 Michael Fulbright 2001-03-20 13:35:06 EST
Thank you for the additional information.

Have you had a chance to try a 7.0 to Wolverine (our second public beta)?
Comment 7 Suhaib Siddiqi 2001-03-20 15:17:42 EST
the latest ISO, works fine from 7.0.
Suhaib
Comment 8 Matt Wilson 2001-03-27 12:16:52 EST
reports working OK now.

Note You need to log in before you can comment on or make changes to this bug.