Bug 295241 - im-chooser is installed and in the menus without any IMs installed by default
im-chooser is installed and in the menus without any IMs installed by default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jens Petersen
Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-18 14:00 EDT by Bill Nottingham
Modified: 2014-03-16 23:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 19:38:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-09-18 14:00:52 EDT
Description of problem:

... which means when you run it you get a ugly error.

Version-Release number of selected component (if applicable):

rawhide-current

Perhaps it shouldn't be installed by default?
Comment 1 Jens Petersen 2007-09-19 00:33:35 EDT
% repoquery -q --whatrequires --repoid=development im-chooser
scim-0:1.4.7-3.fc8.x86_64
kinput2-0:v3.1-34.fc8.x86_64

Hmm, I think all input methods ought to require im-chooser,
so IMHO it is ok to remove im-chooser from comps.

(We should fix im-chooser for this case too anyway: I know
Tagoh-san is planning an update which might help here too.)
Comment 2 Akira TAGOH 2007-09-19 00:49:24 EDT
What the kind of ugly error did you see?
Comment 3 Jens Petersen 2007-09-19 01:06:07 EDT
I changed im-chooser to be optional now in comps, since we don't install
scim by default in F8.

Bill, are you referring to the "No input method available" dialog?
Comment 4 Bill Nottingham 2007-09-19 10:37:56 EDT
Yeah, it's something like:

'No input methods are available - perhaps you'd like to install one?'
Comment 5 Jens Petersen 2007-09-19 19:38:12 EDT
Ok, thanks.

Note You need to log in before you can comment on or make changes to this bug.