Bug 29542 - problems umounting partitions by normal users when LABEL= is used
problems umounting partitions by normal users when LABEL= is used
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Helge Deller
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-26 08:23 EST by Alfredo Ferrari
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-11 11:53:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fstab file (2.12 KB, text/plain)
2001-02-26 08:24 EST, Alfredo Ferrari
no flags Details
mtab at the time the problem occurs (477 bytes, text/html)
2001-02-26 08:26 EST, Alfredo Ferrari
no flags Details
miscellaneous infos (1.39 KB, text/plain)
2001-02-26 08:28 EST, Alfredo Ferrari
no flags Details

  None (edit)
Description Alfredo Ferrari 2001-02-26 08:23:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-3smp i686)


I am experiencing problems in unmounting partitions (only those
defined with the LABEL=... syntax) when logged as a
normal user even though they are flagged "user" in fstab.

More precisely, I can mount them with no problem, but I get a message
like

umount: /work mount disagrees with the fstab

everytime I try to unmount a partition which is identified by "LABEL=..."
in fstab. All partitions given in fstab with the explicit device instead
of the LABEL=... syntax mount and umount with no problem.

As root I can of course umount all partitions flawlessly. I suspect some
permission problem which shows up only for those partitions which use
the LABEL=... syntax in fstab. I do not know if it is a problem of my
machine or a general one.

I include as attachments my fstab file, the mtab file at the time I tried
to unmount as a normal user (/disk2, /disk3, /work do not unmount,
/diskmo, /diske unmount with no problem), and a file containing the error
messages, the kernel version and the version of mount I am using.

P.S. Using the glibc's (i386) and mount from wolverine does not solve the
issue (I have not yet upgraded the kernel)

Reproducible: Always
Steps to Reproduce:
1.define a partition using LABEL=.. in fstab and with user as option
2.mount that partition as a normal user
3.try to umount that partition as a mormal user
	

Actual Results:  The system complains 

umount: /work mount disagrees with the fstab

If root is umounting there is no problem. If the same partition is defined
in fstab using explictly /dev/... instead of LABEL=...
there is no longer any problem in umounting it as a normal user as it
should be


Expected Results:  Of course that a normal user could both mount and umount
partitions flagged with "user" regardless if they are defined thru
LABEL=... or /dev/... inside fstab
Comment 1 Alfredo Ferrari 2001-02-26 08:24:40 EST
Created attachment 11120 [details]
fstab file
Comment 2 Alfredo Ferrari 2001-02-26 08:26:41 EST
Created attachment 11121 [details]
mtab at the time the problem occurs
Comment 3 Alfredo Ferrari 2001-02-26 08:28:09 EST
Created attachment 11122 [details]
miscellaneous infos
Comment 4 Alfredo Ferrari 2001-04-22 12:09:31 EDT
Hi, I am very disappointed to see that the bug is there in RH7.1 SeaWolf as
well. Is there any chance that this bug will ever be looked into or posting bugs
to Bugzilla is just a waste of time since it is there unassigned after two
months?
Comment 5 Helge Deller 2001-06-11 09:06:12 EDT
problem still exists in mount-2.11c-1.rpm
Comment 6 Helge Deller 2001-06-11 11:52:51 EDT
fixed with mount-2.11e-1.src.rpm

Note You need to log in before you can comment on or make changes to this bug.