Bug 295571 - yum traceback when trying to installing i386 java along with x86_64
yum traceback when trying to installing i386 java along with x86_64
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: java-1.5.0-ibm (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Deepak Bhole
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-18 19:44 EDT by Milan Kerslager
Modified: 2010-06-21 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 12:53:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2007-09-18 19:44:27 EDT
I have 64 bit packages with java installed (with %_query_all_fmt
%%{name}-%%{version}-%%{release}.%%{arch}):

# rpm -qa java\*
java-1.5.0-ibm-devel-1.5.0.5-1jpp.0.1.el5.x86_64
java-1.5.0-ibm-1.5.0.5-1jpp.0.1.el5.x86_64

When running this command, traceback occur:

# yum install java-1.5.0-ibm.i386 java-1.5.0-ibm-devel.i386
[...]
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 102, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 359, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 134, in doCommand
    return base.installPkgs(extcmds)
  File "/usr/share/yum-cli/cli.py", line 509, in installPkgs
    self.doRepoSetup()
  File "/usr/share/yum-cli/cli.py", line 107, in doRepoSetup
    self.doSackSetup(thisrepo=thisrepo)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 331, in doSackSetup
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 203, in populateSack
    sack.populate(repo, with, callback, cacheonly)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 88, in populate
    xml = repo.getPrimaryXML()
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 635, in getPrimaryXML
    return self.retrieveMD('primary')
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 622, in retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 208, in _YumRepository__get
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 276, in _noExceptionWrappingGet
    http_headers=headers,
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 927, in
urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 845, in _retry
    r = apply(func, (opts,) + args, {})
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 913, in
retryfunc
    fo = URLGrabberFileObject(url, filename, opts)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 1001, in
__init__
    self._do_open()
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 1072, in
_do_open
    fo, hdr = self._make_request(req, opener)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 1172, in
_make_request
    fo = opener.open(req)
  File "/usr/lib64/python2.4/urllib2.py", line 358, in open
    response = self._open(req, data)
  File "/usr/lib64/python2.4/urllib2.py", line 376, in _open
    '_open', req)
  File "/usr/lib64/python2.4/urllib2.py", line 337, in _call_chain
    result = func(*args)
  File "/usr/lib64/python2.4/site-packages/M2Crypto/m2urllib2.py", line 66, in
https_open
    h.request(req.get_method(), req.get_full_url(), req.data, headers)
  File "/usr/lib64/python2.4/httplib.py", line 807, in request
    if v[0] != 32 or not self.auto_open:
IndexError: tuple index out of range
Comment 1 James Antill 2007-09-19 10:26:22 EDT
 What versions of yum and yum-rhn-plugin, Ie. run:

rpm -q yum yum-rhn-plugin

...also where did you get the x86_64 java packages from, I can't find them on RHN.

 Also why didn't you submit this through https://www.redhat.com/support/ ?
Comment 2 James Antill 2007-09-19 10:34:52 EDT
 Ok, nevermind I've found the x86_64 packages now, and I get (with GA
yum/yum-rhn-plugin):

Transaction Check Error:   file /var/www/cgi-bin/java-rmi-1.5.0.5.cgi from
install of java-1.5.0-ibm-devel-1.5.0.5-1jpp.0.1.el5 conflicts with file from
package java-1.5.0-ibm-devel-1.5.0.5-1jpp.0.1.el5

...this looks like a packaging problem with the java-rmi package not supporting
multilib.
Comment 3 James Antill 2007-09-19 10:37:21 EDT
 Make that the java-1.5.0-ibm-devel-1.5.0.5-1jpp.0.1.el5 package ... and I'm not
sure if that's at least somewhat intentional. In the same way you can't have
multiple libfoo-devel packages installed at once.
Comment 4 Thomas Fitzsimmons 2007-09-19 11:32:09 EDT
(In reply to comment #3)
>  Make that the java-1.5.0-ibm-devel-1.5.0.5-1jpp.0.1.el5 package ... and I'm not
> sure if that's at least somewhat intentional. In the same way you can't have
> multiple libfoo-devel packages installed at once.
> 

None of the JDK packages on the supplementary CD should be marked as multilib in
the yum repository.  This bug prevents alternatives from working correctly in
multilib installations:

https://bugzilla.redhat.com/show_bug.cgi?id=127359
Comment 5 Milan Kerslager 2007-09-19 16:16:45 EDT
I have RHEL 5 with latest updates installed (educational license), so:

yum-3.0.1-5.el5.noarch
yum-rhn-plugin-0.4.3-2.el5.noarch
Comment 6 Deepak Bhole 2010-06-21 12:53:28 EDT
i386 and x86_64 IBM JDK can now be installed in parallel.

Note You need to log in before you can comment on or make changes to this bug.