Bug 295951 - yum gives error when doing upgrade with --skip-broken option
yum gives error when doing upgrade with --skip-broken option
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-19 04:24 EDT by Ashish Shukla
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 07:40:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ashish Shukla 2007-09-19 04:24:33 EDT
Description of problem:
yum gives error when doing upgrade with --skip-broken option.

Version-Release number of selected component (if applicable):
yum-3.2.4.noarch
rpm-4.4.2.1.x86_64
yum-utils-1.1.6.noarch

How reproducible:
Everytime.

Steps to Reproduce:
1. Execute "yum upgrade -y --skip-broken" .
2.
3.
  
Actual results:
Yum gives error.

Expected results:
Should upgrade fine without any error.

Additional info:
Refer to following dump for information.

-- begin dump --
[wahjava@chatteau ~]$ sudo yum upgrade -y
Password:
Loading "presto" plugin
Loading "refresh-updatesd" plugin
Loading "merge-conf" plugin
Loading "kernel-module" plugin
Loading "security" plugin
Loading "allowdowngrade" plugin
Loading "skip-broken" plugin
Loading "downloadonly" plugin
Loading "tsflags" plugin
Loading "fedorakmod" plugin
Loading "fastestmirror" plugin
Loading "priorities" plugin
Loading "changelog" plugin
Loading "protectbase" plugin
Setting up Presto
Reading Presto metadata in from local files
Loading mirror speeds from cached hostfile
0 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package gnupg2.x86_64 0:2.0.6-2.fc7 set to be updated
---> Package yum-security.noarch 0:1.1.7-1.fc7 set to be updated
---> Package tor-core.x86_64 0:0.1.2.17-1.fc7 set to be updated
---> Package lesstif-mwm.x86_64 0:0.95.0-20.fc7 set to be updated
---> Package SDL-devel.i386 0:1.2.12-1.fc7 set to be updated
---> Package Canna-libs.x86_64 0:3.7p3-21.fc7 set to be updated
---> Package mod_ssl.x86_64 1:2.2.6-1.fc7 set to be updated
---> Package yum-downloadonly.noarch 0:1.1.7-1.fc7 set to be updated
---> Package qt-devel-docs.x86_64 1:3.3.8-7.fc7 set to be updated
---> Package yum-tsflags.noarch 0:1.1.7-1.fc7 set to be updated
---> Package tor.x86_64 0:0.1.2.17-1.fc7 set to be updated
---> Package lesstif-devel.x86_64 0:0.95.0-20.fc7 set to be updated
---> Package zeroinstall-injector.noarch 0:0.30-2.fc7 set to be updated
---> Package lesstif.x86_64 0:0.95.0-20.fc7 set to be updated
---> Package SDL.i386 0:1.2.12-1.fc7 set to be updated
---> Package yum.noarch 0:3.2.5-1.fc7 set to be updated
---> Package selinux-policy.noarch 0:2.6.4-42.fc7 set to be updated
---> Package dhcpv6_client.x86_64 0:0.10-44.fc7 set to be updated
---> Package procps.x86_64 0:3.2.7-16.fc7 set to be updated
---> Package php.x86_64 0:5.2.4-1.fc7 set to be updated
---> Package php-pdo.x86_64 0:5.2.4-1.fc7 set to be updated
---> Package yum-fedorakmod.noarch 0:1.1.7-1.fc7 set to be updated
---> Package yum-fastestmirror.noarch 0:1.1.7-1.fc7 set to be updated
---> Package SDL.x86_64 0:1.2.12-1.fc7 set to be updated
---> Package tango-icon-theme.noarch 0:0.8.1-1.fc7 set to be updated
---> Package gazpacho.noarch 0:0.7.2-2.fc7 set to be updated
--> Processing Dependency: python-kiwi-gazpacho for package: gazpacho
---> Package yum-skip-broken.noarch 0:1.1.7-1.fc7 set to be updated
---> Package tor-lsb.x86_64 0:0.1.2.17-1.fc7 set to be updated
---> Package qt-devel.x86_64 1:3.3.8-7.fc7 set to be updated
---> Package dhclient.x86_64 12:3.0.5-40.fc7 set to be updated
---> Package yum-priorities.noarch 0:1.1.7-1.fc7 set to be updated
---> Package yum-protectbase.noarch 0:1.1.7-1.fc7 set to be updated
---> Package httpd-manual.x86_64 0:2.2.6-1.fc7 set to be updated
---> Package kvm.x86_64 0:35-2.fc7 set to be updated
---> Package php-ldap.x86_64 0:5.2.4-1.fc7 set to be updated
---> Package system-config-samba.noarch 0:1.2.52-1.fc7 set to be updated
---> Package python-virtinst.noarch 0:0.200.0-3.fc7 set to be updated
---> Package selinux-policy-devel.noarch 0:2.6.4-42.fc7 set to be updated
---> Package yum-versionlock.noarch 0:1.1.7-1.fc7 set to be updated
---> Package qt.i386 1:3.3.8-7.fc7 set to be updated
---> Package linuxwacom.i386 0:0.7.6.4-3.fc7 set to be updated
---> Package yum-allowdowngrade.noarch 0:1.1.7-1.fc7 set to be updated
---> Package telepathy-glib.x86_64 0:0.5.14-1.fc7 set to be updated
---> Package yum-kernel-module.noarch 0:1.1.7-1.fc7 set to be updated
---> Package SDL-devel.x86_64 0:1.2.12-1.fc7 set to be updated
---> Package libdhcp6client.x86_64 0:0.10-44.fc7 set to be updated
---> Package php-mysql.x86_64 0:5.2.4-1.fc7 set to be updated
---> Package selinux-policy-targeted.noarch 0:2.6.4-42.fc7 set to be updated
---> Package yum-merge-conf.noarch 0:1.1.7-1.fc7 set to be updated
---> Package leafpad.x86_64 0:0.8.11-1.fc7 set to be updated
---> Package iptstate.x86_64 0:2.2.1-1.fc7 set to be updated
---> Package dhcpv6.x86_64 0:0.10-44.fc7 set to be updated
---> Package lesstif-clients.x86_64 0:0.95.0-20.fc7 set to be updated
---> Package libdhcp4client.x86_64 12:3.0.5-40.fc7 set to be updated
---> Package php-common.x86_64 0:5.2.4-1.fc7 set to be updated
---> Package metacity.i386 0:2.18.5-2.fc7 set to be updated
---> Package qt-devel.i386 1:3.3.8-7.fc7 set to be updated
---> Package yum-refresh-updatesd.noarch 0:1.1.7-1.fc7 set to be updated
---> Package lesstif.i386 0:0.95.0-20.fc7 set to be updated
---> Package system-config-users.noarch 0:1.2.64-1.fc7 set to be updated
---> Package empathy.x86_64 0:0.12-1.fc7 set to be updated
--> Processing Dependency: libmissioncontrol-client.so.0()(64bit) for package: 
empathy
---> Package libsmbios-libs.x86_64 0:0.13.10-1.fc7 set to be updated
---> Package php-cli.x86_64 0:5.2.4-1.fc7 set to be updated
---> Package libtirpc.x86_64 0:0.1.7-9.fc7 set to be updated
---> Package metacity.x86_64 0:2.18.5-2.fc7 set to be updated
---> Package telepathy-glib-devel.x86_64 0:0.5.14-1.fc7 set to be updated
---> Package yum-changelog.noarch 0:1.1.7-1.fc7 set to be updated
---> Package anjuta.x86_64 1:2.2.0-2.fc7 set to be updated
---> Package yum-updatesd.noarch 0:3.2.5-1.fc7 set to be updated
---> Package qt.x86_64 1:3.3.8-7.fc7 set to be updated
---> Package telepathy-glib-unstable-static.x86_64 0:0.5.14-1.fc7 set to be 
updated
---> Package system-config-date.noarch 0:1.9.5-1.fc7 set to be updated
---> Package linuxwacom.x86_64 0:0.7.6.4-3.fc7 set to be updated
---> Package qt-designer.x86_64 1:3.3.8-7.fc7 set to be updated
---> Package yum-utils.noarch 0:1.1.7-1.fc7 set to be updated
---> Package httpd.x86_64 0:2.2.6-1.fc7 set to be updated
--> Running transaction check
---> Package python-kiwi-gazpacho.noarch 0:1.9.14-1.fc7 set to be updated
--> Processing Dependency: python-kiwi = 1.9.14-1.fc7 for package: 
python-kiwi-gazpacho
---> Package empathy.x86_64 0:0.12-1.fc7 set to be updated
--> Processing Dependency: libmissioncontrol-client.so.0()(64bit) for package: 
empathy
--> Running transaction check
---> Package python-kiwi.noarch 0:1.9.14-1.fc7 set to be updated
---> Package empathy.x86_64 0:0.12-1.fc7 set to be updated
--> Processing Dependency: libmissioncontrol-client.so.0()(64bit) for package: 
empathy
--> Finished Dependency Resolution
Error: Missing Dependency: libmissioncontrol-client.so.0()(64bit) is needed by 
package empathy
[wahjava@chatteau ~]$ sudo yum upgrade -y --skip-broken
Password:
Loading "presto" plugin
Loading "refresh-updatesd" plugin
Loading "merge-conf" plugin
Loading "kernel-module" plugin
Loading "security" plugin
Loading "allowdowngrade" plugin
Loading "skip-broken" plugin
Loading "downloadonly" plugin
Loading "tsflags" plugin
Loading "fedorakmod" plugin
Loading "fastestmirror" plugin
Loading "priorities" plugin
Loading "changelog" plugin
Loading "protectbase" plugin
Setting up Presto
fedora                    100% |=========================| 2.1 kB    00:00
livna                     100% |=========================| 2.1 kB    00:00
updates                   100% |=========================| 2.3 kB    00:00
Reading Presto metadata in from local files
Loading mirror speeds from cached hostfile
0 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Setting up Upgrade Process
Resolving Dependencies
**** Checking packages for dependency problems
**** Checking for dep problems  : gnupg2 - 2.0.6-2.fc7.x86_64
--> Running transaction check
---> Package gnupg2.x86_64 0:2.0.6-2.fc7 set to be updated
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 143, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 564, in 
buildTransaction
    self.plugins.run('preresolve')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/skip-broken.py", line 122, in preresolve_hook
    (good,bad) = cd.preDepCheck()
  File "/usr/lib/yum-plugins/skip-broken.py", line 64, in preDepCheck
    (rescode, restring) = self.base.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 718, in 
resolveDeps
    for po, dep in self._checkFileRequires():
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 921, in 
_checkFileRequires
    if not self.tsInfo.getOldProvides(filename) and not 
self.tsInfo.getNewProvides(filename):
  File "/usr/lib/python2.5/site-packages/yum/transactioninfo.py", line 393, in 
getOldProvides
    for pkg, hits in self.rpmdb.getProvides(name, flag, version).iteritems():
AttributeError: 'NoneType' object has no attribute 'getProvides'
-- end dump --
Comment 1 Ashish Shukla 2007-09-19 04:37:55 EDT
I just noticed there are also upgrades for 'yum*' packages, so I individually 
upgraded 'yum*' packages, and after this, 'yum upgrade -y --skip-broken' 
worked fine. Sorry for this bug report.

Note You need to log in before you can comment on or make changes to this bug.