Bug 296011 - Physical Memory swinging up and down by 100 megabytes when there is no physical change to the system.
Physical Memory swinging up and down by 100 megabytes when there is no physic...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
ia64 Linux
low Severity high
: ---
: ---
Assigned To: Red Hat Kernel Manager
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-19 05:02 EDT by Sameer Uddin
Modified: 2008-01-22 14:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 14:57:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sameer Uddin 2007-09-19 05:02:11 EDT
Description of problem:

HP-OVPA(Open view performance agent) is a tool used to monitor the system 
performance. The daemon Scopeux is the main component which collects system 
data and logs into the log file. This component gets started at the boottime 
by default or can be manually started after boottime. 

Now the problem is the size of Physical memory got from the /proc/meminfo 
file. Basically Scopeux takes the data from /proc/meminfo and logs it into the 
logfile. When Scopeux is started as part of system bootup, the value seen in 
measurement for physical memory is over 100 megabytes larger than the value 
seen when scopeux is restarted once bootup is completed.

Showing physical memory swinging up and down by 100 megabytes at a time when 
there is no physical change to the system is a problem. 


Version-Release number of selected component (if applicable):


How reproducible:

System Details: 
uname -a
Linux  ovrlxt66.rose.hp.com 2.6.18-8.el5 #1 SMP Fri Jan 26 14:16:09 EST 2007 
ia64

vi /etc/issue
Red Hat Enterprise Linux Server release 5 (Tikanga)
Kernel \r on an \m

Steps to Reproduce:
1. Note the Physical memory(MemTotal) got from /proc/meminfo.
2. reboot the system
3. Note the Physical memory got at boottime. You can see a difference in 
Physical memory got at boottime to what you got after boottime. 
  
Actual results:
At boottime
MemTotal:       981.0 MBytes
After boottime
MemTotal:       863.0 MBytes

Expected results:
At boottime
MemTotal:       863.0 MBytes
After boottime
MemTotal:       863.0 MBytes

Additional info:
Comment 1 Tomas Smetana 2007-09-20 02:47:59 EDT
Hm...  I thought to get know the first real user of procinfo utility and it's
only a misfit bug.  This is not for procinfo -- it's for the kernel.
Comment 2 Neil Horman 2008-01-22 14:57:11 EST
Why is this a problem?  Just becuase a system doesn't change physical state,
doesnt mean we can't change the amount of ram present during the boot process,
or after the boot process for that matter.  xen dom0 kernels do this to provide
system memory to guest kernels.  Some arches remove the zero pages from the
totalrampage count during boot up since those pages will never be used.  It may
look a bit funny in your monitoring, but there isn't anything wrong with it.

Note You need to log in before you can comment on or make changes to this bug.