This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 296111 - wrong permissions for /dev/sg*
wrong permissions for /dev/sg*
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-19 07:39 EDT by mail@romal.de
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 09:00:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description mail@romal.de 2007-09-19 07:39:30 EDT
Description of problem:

[romal@beowulf ~]$ ll /dev/sg*
crw-r----- 1 root disk 21, 0 19. Sep 11:54 /dev/sg0
crw-r----- 1 root disk 21, 1 19. Sep 11:54 /dev/sg1
[romal@beowulf ~]$ 

Logged in user does not have access to the cdwriter

Version-Release number of selected component (if applicable):

udev-115-2.fc8

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Commercial Nero cdwriting software (www.nero.com) does complain on this if
running as non-root-user.
Comment 1 Harald Hoyer 2007-09-19 09:00:04 EDT
you should use /dev/sr* (/dev/cdrom) not sg. We cannot allow general user access
to sg, because you can do bad things with it (like flashing a new firmware, etc.)

Note You need to log in before you can comment on or make changes to this bug.