Bug 296391 - Hang during boot
Hang during boot
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: grub (Show other bugs)
5.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Václav Pavlín
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-19 10:21 EDT by Michael Hurley
Modified: 2013-01-17 03:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-17 03:08:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Hurley 2007-09-19 10:21:09 EDT
Description of problem:
After installing the latest Xen kernel (2.6.18-8.1.10.el5xen #1 SMP), the system
hung on reboot. It displayed the graphical boot screen, stuck on "Setting the
hostname." The mouse still responded, and the machine responded to a ping, but
otherwise was completely unresponsive. Had to physically reset it. Edited rhgb
out of grub.conf and booted the latest kernel without any problem. 

Version-Release number of selected component (if applicable):
kernel-xen-2.6.18-8.1.10.el5

How reproducible:
very

Steps to Reproduce:
1. boot with kernel-xen-2.6.18-8.1.10.el5 selected and rhgb in grub.conf
  
Actual results:
Hangs in boot screen

Expected results:
finish boot up

Additional info:
Here is what was written to /var/log/messages:
Sep 19 09:34:36 ginsburg kernel: bnx2: eth0 NIC Link is Up, 100 Mbps full duplex
Sep 19 09:34:36 ginsburg kernel: bnx2: eth0 NIC Link is Down
Sep 19 09:34:36 ginsburg kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready
Sep 19 09:34:36 ginsburg kernel: bnx2: eth0 NIC Link is Up, 100 Mbps full duplex
Sep 19 09:34:36 ginsburg kernel: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Sep 19 09:34:36 ginsburg kernel: audit(1190208876.132:4): audit_pid=2570 old=0
by auid=42949
67295 subj=system_u:system_r:auditd_t:s0
Sep 19 09:49:31 ginsburg syslogd 1.4.1: restart.

On the successful boot, the next line after the SELinux message is:
Sep 19 09:49:31 ginsburg mcstransd: mcstransd starting
Comment 1 Vladimir Serbinenko 2012-08-01 17:25:17 EDT
This is 99% sure not a GRUB issue at all since kernel has loaded successfully. Most likely it's a problem in kerenel or init scripts.
Comment 2 Václav Pavlín 2013-01-14 09:24:26 EST
Hi,

Looks as Vladimir writes - kernel loaded successfully, so it won't be the grub issue. Could you still reproduce this issue with latest grub, kernel and initscripts?

Regards

Vaclav Pavlin
Comment 3 Michael Hurley 2013-01-14 17:32:42 EST
I filed this report over 5 years ago. I'm no longer at the job I had then, and so no longer working with those systems. I barely recall this event at all. So i'm afraid i won't be much help reproducing this issue. However, it's probably safe to say it's not a major issue anymore.
Comment 4 Václav Pavlín 2013-01-17 03:08:00 EST
Ok, thanks. So closing for now.

Note You need to log in before you can comment on or make changes to this bug.