Bug 296511 - xlockmore does not work with Xorg 1.3.0
xlockmore does not work with Xorg 1.3.0
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-19 12:04 EDT by Thomas Woerner
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 10:12:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Configuration with vesa driver (1.32 KB, application/octet-stream)
2007-09-20 05:48 EDT, Thomas Woerner
no flags Details
Log file using vesa driver. (66.25 KB, text/plain)
2007-09-20 05:49 EDT, Thomas Woerner
no flags Details
lspci output (2.96 KB, application/octet-stream)
2007-09-20 05:49 EDT, Thomas Woerner
no flags Details
Logging output without /etc/X11/xorg.xconf (30.90 KB, application/octet-stream)
2007-09-20 05:50 EDT, Thomas Woerner
no flags Details

  None (edit)
Description Thomas Woerner 2007-09-19 12:04:23 EDT
Description of problem:
$ xlock -mode swarm -nolock
xlock: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Aborted

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.3.0.0-24.fc8

How reproducible:
Always

Steps to Reproduce:
1. xlock -mode swarm
2.
3.
  
Actual results:
Error message

Expected results:
Working xlock

Additional info:
Rebuilding the xlockmore package did not help.
Comment 1 Thomas Woerner 2007-09-19 12:23:42 EDT
Same problem with xscreensaver:
$ xscreensaver
xscreensaver-gl-helper: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock'
failed.
xscreensaver-gl-helper: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock'
failed.
Comment 2 Matěj Cepl 2007-09-19 15:50:26 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Thomas Woerner 2007-09-20 05:48:07 EDT
Created attachment 200591 [details]
Configuration with vesa driver

I have sucessfully verified the problem with the original vesa driver from F-8,
because I have patched the xorg-x11-drv-ati driver to regognize the ATI FireMV
2400 card here. I can use the card with up to four screens with Xinerama.
Comment 4 Thomas Woerner 2007-09-20 05:49:01 EDT
Created attachment 200601 [details]
Log file using vesa driver.
Comment 5 Thomas Woerner 2007-09-20 05:49:25 EDT
Created attachment 200611 [details]
lspci output
Comment 6 Thomas Woerner 2007-09-20 05:50:18 EDT
Created attachment 200621 [details]
Logging output without /etc/X11/xorg.xconf

The server is not able to start up.
Comment 7 Thomas Woerner 2007-09-20 10:12:50 EDT
I did a clean installation on the machine and it does not have the problem. I
have verified the installations and they are nearly identical: same packages and
X configuraiton. rpm -Va does not report anything which is X related.
I can not say, why the first does not work and the new one does.

I am closing this as "NOT A BUG".

Note You need to log in before you can comment on or make changes to this bug.