Bug 296681 - kernel panic in snd_hda_intel on startup Dell Latitude D630
kernel panic in snd_hda_intel on startup Dell Latitude D630
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
All Linux
low Severity high
: ---
: ---
Assigned To: John Feeney
Red Hat Kernel QE team
:
Depends On:
Blocks: 425461
  Show dependency treegraph
 
Reported: 2007-09-19 13:42 EDT by Michal Babej
Modified: 2013-07-31 19:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-26 14:28:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kernel dump (2.22 KB, text/plain)
2007-09-19 14:41 EDT, Michal Babej
no flags Details
"lspci -nv" from the laptop (5.84 KB, text/plain)
2007-09-20 10:53 EDT, Michal Babej
no flags Details
lspci output - system does not panic (8.11 KB, text/plain)
2007-09-21 14:02 EDT, Mike Gahagan
no flags Details

  None (edit)
Description Michal Babej 2007-09-19 13:42:45 EDT
Description of problem:
kernel panic on startup

Version-Release number of selected component (if applicable):
RHEL 5.1 Beta Snapshot 7

How reproducible:
always

Steps to Reproduce:
1. install RHEL 5.1 beta
2. restart after install
3. kernel panic in snd_hda_codec

Additional info:
The machine is a new laptop Dell Latitude D630 (Intel 965GM chipset)
Comment 1 Michal Babej 2007-09-19 14:41:36 EDT
Created attachment 199951 [details]
kernel dump
Comment 2 Michal Babej 2007-09-19 14:49:12 EDT
actually i was mistaken. snd_hda_codec loads fine - i get the panic after
loading snd_hda_intel.
Comment 4 Mike Gahagan 2007-09-20 10:18:06 EDT
would be good to know how many other systems this affects... i.e. just this
system or anything with this sound chipset.
Comment 5 Michal Babej 2007-09-20 10:53:24 EDT
Created attachment 200801 [details]
"lspci -nv" from the laptop
Comment 6 Brian Maly 2007-09-20 14:20:19 EDT
Can you provide a stack trace possibly?
Comment 7 Brian Maly 2007-09-20 14:23:34 EDT
Re Comment #6:

Boot and try loading the module manually, capture the panic. Thats the stack
trace Im interested in.
Comment 8 Mike Gahagan 2007-09-20 15:33:49 EDT
I have a desktop system on my desk with what looks like the same if not a very
similar audio chipset. I'll try out sound on it tomorrow morning.
Comment 9 Michal Babej 2007-09-21 04:20:20 EDT
Re comment #6:

i've provided a stack trace in comment #1 ? or is it a wrong one ?

it's a stack trace from kernel panic i got after running 'modprobe
snd_hda_intel', captured with kdump.
Comment 10 Brian Maly 2007-09-21 13:28:55 EDT
Stack trace in comment #1 seems to be from alsaunmute being executed. I was
looking for stack trace from when snd_hda_intel is loaded instead.

Do both panics occur in the same place? I.e. would the stack trace from Comment
#1 and the panic from loading snd_hda_intel be identical?

Comment 11 Michal Babej 2007-09-21 14:00:01 EDT
yes, that's right.
Comment 12 Mike Gahagan 2007-09-21 14:00:48 EDT
ok, the desktop system I have does not panic with the -48.el5 kernel. It boots
up and the sound works just fine from what I can tell. 

I'll attach lspci output
Comment 13 Mike Gahagan 2007-09-21 14:02:09 EDT
Created attachment 202661 [details]
lspci output - system does not panic
Comment 14 Larry Troan 2007-09-24 14:15:00 EDT
Rez, can you tell us what other Dell systems have this CODEC?
Comment 16 Larry Troan 2007-09-25 10:22:41 EDT
On Mon, 2007-09-24 at 15:42 -0500, Rezwanul_Kabir@Dell.com wrote:
> What do the M65 and M90 have?
> 
>   Oh yes, M65 at least has STAC9200. Need to check M90..
> 
Red Hat should have an M65 in Westford. I have an M90 in my office in Raleigh.
The M90 is currently running the x86 arch of the 8/17 beta code plus the
2.6.18-48.el5 kernel. I'm not aware of how to test for the specific CODEC in
software.
Comment 17 Rezwanul Kabir 2007-09-25 11:09:33 EDT
Both M65 and M90 have STAC9200 audio codec..
Comment 20 Brian Maly 2007-09-26 12:17:46 EDT
Is this a regression? Did this used to work in 5.0? Or did this never ever work?

Trying to determine if this was a regression introduced with the 1.0.14 ALSA
update in 5.1 or not.
Comment 23 Michal Babej 2007-09-26 13:48:27 EDT
So, I have tested Snapshot 8 (48.el5), behaves exactly the same way.

So i tried RHEL 5 GA, it boots, loads snd_hda_intel. However, running alsamixer
results in kernel panic.

I checked microphone settings, it was disabled. After enabling, alsamixer starts
up without kernel panic. So - CLOSED/duplicate ?
Comment 24 John Feeney 2007-09-26 14:00:53 EDT
Well, that's good that it is similar (not sure why the microphone is allowed
to be disabled). 

My bugzilla deals with STAC9205 codecs, not STAC9200 so they are close but
not exactly the same (maybe I'm splitting hairs). Maybe keep it opened
but assign it to me? How's that sound, Brian?
Comment 25 Brian Maly 2007-09-26 14:14:06 EDT
There is new support for STAC9205 upstream in alsa-driver-1.0.15rc3. The
STAC9200 support has been there for a little while, so not sure if this got
broken by the recent ALSA update or not. There are also a bunch of updates in
patch_sigmatel for newer dell models.




Comment 26 John Feeney 2007-09-26 14:23:55 EDT
Yeah, you are probably referring to what Sigmatel added for the STAC9205-specific
Dell laptops. I have a patch all worked up and am waiting for Dell to test it.

Comment 30 Rui Matos 2007-10-15 16:10:51 EDT
Just FYI on my latitude d630 the kernel also crashes when snd_hda_intel loads if
I disable the microphone in the BIOS, otherwise it works fine. This is on Fedora
7 with kernel 2.6.22.9-91.fc7.
Comment 31 John Feeney 2007-10-25 14:09:48 EDT
Just to bring some closure to this, perhaps someone could test the kernel
with the patch for STAC9205. See people.redhat.com/jfeeney/.bz254067. 
Note: The only rpm there is for the x86_64 platform. Thanks.
Comment 33 Brian Maly 2007-12-13 19:48:41 EST
Can someone with the affected hardware test Johns kernel mentioned in Comment #31?
Comment 34 John Feeney 2008-03-04 17:20:27 EST
I tried to foist testing of this off on Dell, thinking they must have a 
Lattitude D630 readily available, but they don't. Michal, since you reported it,
could you test this please (unless you don't have the laptop anymore)? Thanks 
in advance if you can. 
Comment 35 Rui Matos 2008-03-04 18:58:48 EST
FWIW, this doesn't happen to me anymore with kernel 
kernel-2.6.23.15-137.fc8.x86_64
Comment 36 Michal Babej 2008-03-05 04:40:50 EST
Unfortunately i don't have the laptop anymore.
Comment 37 Jaroslav Kysela 2008-06-12 09:35:14 EDT
Patch bug#451007 might solve this issue in RHEL5.3
Comment 38 RHEL Product and Program Management 2008-07-25 13:07:22 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 39 Ludek Smid 2008-07-25 17:55:05 EDT
Unfortunately the previous automated notification about the
non-inclusion of this request in Red Hat Enterprise Linux 5.3 used
the wrong text template. It should have read: this request has been
reviewed by Product Management and is not planned for inclusion
in the current minor release of Red Hat Enterprise Linux.

If you would like this request to be reviewed for the next minor
release, ask your support representative to set the next rhel-x.y
flag to "?" or raise an exception.
Comment 40 RHEL Product and Program Management 2009-02-16 10:45:19 EST
Updating PM score.

Note You need to log in before you can comment on or make changes to this bug.