Bug 29686 - Internal compiler error in fixup_var_refs_1
Internal compiler error in fixup_var_refs_1
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
: 31076 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-26 20:24 EST by ans124
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-27 09:51:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is the maxwell_eps.i file (115.53 KB, application/octet-stream)
2001-02-27 05:46 EST, ans124
no flags Details

  None (edit)
Description ans124 2001-02-26 20:24:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14 i686)


gcc crashes whet trying to compile the MIT Photonic-Bands 1.0 program,
available from http://ab-initio.mit.edu/mpb/download.html


Reproducible: Always
Steps to Reproduce:
1. Install fftw, blas, guile, libctl (from
http://superjdj.mit.edu/libctl/),...
2. cd mpb-1.0; ./configure
3. make
Note: the compiler is gcc-2.96-69


Actual Results:  ...
cc -DHAVE_CONFIG_H -I/usr/include  -I../util -I../matrices -c -O3 -Wall -W
-Wbad-function-cast -Wcast-qual -Wpointer-arith -Wcast-align -pedantic
maxwell_eps.c -o maxwell_eps.o
In file included from /usr/include/math.h:348,
                 from maxwell_eps.c:20:
/usr/include/bits/mathinline.h:186:30: warning: ISO C does not permit named
varargs parameters
/usr/include/bits/mathinline.h:190:32: warning: ISO C does not permit named
varargs parameters
/usr/include/bits/mathinline.h:201:30: warning: ISO C does not permit named
varargs parameters
/usr/include/bits/mathinline.h:205:32: warning: ISO C does not permit named
varargs parameters
maxwell_eps.c: In function `set_maxwell_dielectric':
maxwell_eps.c:838: Internal compiler error in fixup_var_refs_1, at
function.c:1877
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [maxwell_eps.o] Error 1
make[1]: Leaving directory
`/mnt/scratch/linux/math/mpb/mpb-1.0/src/maxwell'
make: *** [all-recursive] Error 1


Expected Results:  the mpb executable should have been created

Authors comment from http://ab-initio.mit.edu/mpb/download.html
Linux/x86: There is a bug in gcc 2.95.[01] (and possibly earlier egcs
versions) that causes
    problems. This was fixed in gcc 2.95.2. (gcc 2.8.1 and earlier seem to
be okay, too.) The gcc
    "2.96" version released with Redhat 7.0 also seems to cause problems
(generate NaNs),
    although we haven't yet tracked this down in detail; we recommend using
gcc 2.95.2 instead.
Comment 1 Jakub Jelinek 2001-02-27 03:24:52 EST
Can you please rerun
cc -DHAVE_CONFIG_H -I/usr/include  -I../util -I../matrices -c -O3 -Wall -W -Wbad-function-cast -Wcast-qual -Wpointer-arith -Wcast-align -pedantic maxwell_eps.c -o maxwell_eps.o -save-temps -v
and attach here maxwell_eps.i?
There have been some fixup_var_refs fixes between gcc-2.96-69 and gcc-2.96-77,
so it is well possible this is fixed already, but I'd like to be sure.
Comment 2 ans124 2001-02-27 05:46:12 EST
Created attachment 11165 [details]
Here is the maxwell_eps.i file
Comment 3 Jakub Jelinek 2001-02-27 06:21:06 EST
Looks like it is not fixed, happens with gcc 3.0 and 3.1 branches as well.
It can be simplified into:
void foo (void)
{
  double a = 0.0;
  double b = a;
  if (&b != &a);
}
which ICEs at -O and above.
Debugging...
Comment 4 Jakub Jelinek 2001-02-27 09:51:41 EST
I've fixed this in http://gcc.gnu.org/ml/gcc-patches/2001-02/msg01615.html,
waiting for feedback before I put it into rpm.
Comment 5 Jakub Jelinek 2001-03-07 06:08:00 EST
The fix is in gcc-2.96-77.1 in rawhide.
Comment 6 Jakub Jelinek 2001-03-08 12:55:27 EST
*** Bug 31076 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.