Bug 296911 - azureus won't run on Fedora (dev version as of 2007-09-19)
azureus won't run on Fedora (dev version as of 2007-09-19)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-19 16:11 EDT by Robin Bowes
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-22 14:00:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Azureus crash log (64.50 KB, text/plain)
2007-10-07 04:49 EDT, Julian Sikorski
no flags Details
Yet another crash log (64.79 KB, text/plain)
2007-11-22 13:41 EST, Julian Sikorski
no flags Details

  None (edit)
Description Robin Bowes 2007-09-19 16:11:49 EDT
Description of problem:

azureus won't run

Version-Release number of selected component (if applicable):

azureus-2.5.0.4-2.fc7.x86_64

How reproducible:

Run azureus - it doesn't start!

Steps to Reproduce:
1. Select "azureus" from "Applications|Internet" menu
2. 
3.
  
Actual results:

Azureus fails to start

Expected results:

Azureus starts

Additional info:

When run from a terminal, the following error output is produced:

Exception in thread "main" java.lang.NoClassDefFoundError:
org/eclipse/swt/widgets/Display
        at org.gudy.azureus2.ui.swt.Main.<init>(Main.java:80)
        at org.gudy.azureus2.ui.swt.Main.main(Main.java:180)
Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.widgets.Display
        at java.net.URLClassLoader$1.run(URLClassLoader.java:221)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:209)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:324)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:269)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:337)
        ... 2 more

This is using "icedtea":

]$ java -version
java version "1.7.0"
IcedTea Runtime Environment (build 1.7.0-kojibuilder_07_sep_2007_16_33-b00)
IcedTea 64-Bit Server VM (build 11.0-b05, mixed mode)
Comment 1 Robin Bowes 2007-09-19 16:13:37 EDT
It isn't clear from the ticket, but I'm running the latest devel version of
fedora. i.e. Rawhide:

$ cat /etc/redhat-release 
Fedora release 7.91 (Rawhide)

I'm up-to-date as of 2007-09-19.
Comment 2 Bart Vanbrabant 2007-09-27 03:23:16 EDT
The problem is swt got update from 3.2 to 3.3 and the wrong jar is added to the
classpath in the wrapper script that start azureus.
You can change the version in the jar name from 3.2 to 3.3 in /usr/bin/azureus
Comment 3 Robin Bowes 2007-09-27 07:19:29 EDT
Bart, thanks for the update.

I don't have a rawhide machine to test this on at the moment (have given up
running it as my main desktop - too troublesome!) but when I get a moment I'll
kickstart a dev install on my xen server and check this out.

Thanks again.

R.
Comment 4 Thomas Fitzsimmons 2007-10-04 18:35:17 EDT
Fixed in azureus-2.5.0.4-3.fc8.
Comment 5 Julian Sikorski 2007-10-07 04:48:07 EDT
azureus-2.5.0.4-3.fc8 still does not start for me:

[jsikorski@snowball ~]$ azureus
DEBUG::Sun Oct 07 10:45:51 CEST
2007::com.aelitis.azureus.core.impl.AzureusCoreImpl$8::runSupport::512:
  java.lang.NullPointerException
        at
org.gudy.azureus2.ui.swt.updater2.SWTUpdateChecker.initialize(SWTUpdateChecker.java:67)
        at
org.gudy.azureus2.ui.swt.mainwindow.Initializer$4.started(Initializer.java:258)
        at
com.aelitis.azureus.core.impl.AzureusCoreImpl$8.runSupport(AzureusCoreImpl.java:508)
        at org.gudy.azureus2.core3.util.AEThread.run(AEThread.java:69)

#
# An unexpected error has been detected by Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00002aaaaae17f26, pid=6260, tid=1074792784
#
# Java VM: IcedTea 64-Bit Server VM (11.0-b05 mixed mode linux-amd64)
# Problematic frame:
# V  [libjvm.so+0x345f26]
#
# An error report file with more information is saved as:
# /home/jsikorski/hs_err_pid6260.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Comment 6 Julian Sikorski 2007-10-07 04:49:04 EDT
Created attachment 218611 [details]
Azureus crash log
Comment 7 Anthony Green 2007-11-11 15:50:52 EST
I'm moving this over to the icedtea queue.  I'll note, however, that I have no
problem running azureus on icedtea on F8.
Comment 8 Lillian Angel 2007-11-22 11:23:59 EST
I can't reproduce this with:
azureus.x86_64 0:2.5.0.4-4.fc9
java-1.7.0-icedtea b23

any more info?
Comment 9 Julian Sikorski 2007-11-22 13:27:24 EST
I am seeing this under Fedora 8.
azureus-2.5.0.4-3.fc8.x86_64
java-1.7.0-icedtea-1.7.0.0-0.19.b21.snapshot.fc8.x86_64
java-1.5.0-gcj-1.5.0.0-17.fc8.x86_64

This bug has far less information that #282811. Looking at it now, it looks the
fault does not lie on the azureus side entirely. Same The situation seems to be
different now. Keep in mind that I used to post info into bug #212811, but I am
not sure if it really describes the same issue. To cut the story short:
1. java-1.7.0-icedtea
azureus crashes right after startup with the message I posted above. I have also
noticed that the crash log differs from time to time. So far, I have seen two
different problematic frames, libjvm.so and libgtkjni-2.8.so

2. java-1.5.0-gcj
azureus starts, but as soon as you click anything, it aborts with the following
message:
(process:11456): Gtk-WARNING (recursed) **: gtk_scrolled_window_add(): cannot
add non scrollable widget use gtk_scrolled_window_add_with_viewport() instead
aborting...

I could try to debug the process further provided you supplied me with some
guidance.
Comment 10 Julian Sikorski 2007-11-22 13:29:13 EST
Ugh, the beggining of the post is confusing. Sorry. Ignore the part of the
description before “Keep in mind”.
Comment 11 Lillian Angel 2007-11-22 13:33:11 EST
Can you try installing IcedTea from rawhide? 
java-1.7.0-icedtea-1.7.0.0-0.20.b23.snapshot.fc9.x86_64

Comment 12 Julian Sikorski 2007-11-22 13:41:18 EST
Created attachment 267211 [details]
Yet another crash log

Still no luck.
Comment 13 Julian Sikorski 2007-11-22 13:47:21 EST
Hmm, I nuked my config and the program now magically works. Did you try starting
up the program with some torrents present?
Comment 14 Julian Sikorski 2007-11-22 13:56:59 EST
OK, I think I might have narrowed it down. It starts with fresh config, but as
soon as I try to add a torrent, it goes down: Open torrent > browse > change the
torrent location.
Comment 15 Lillian Angel 2007-11-22 14:00:01 EST
Ok this is related to:
https://bugzilla.redhat.com/show_bug.cgi?id=376111
Comments about torrent bugs would be more relevant there.

I am closing this bug report.
Comment 16 Robin Bowes 2007-11-22 14:21:46 EST
I'm a little late to the party with this one, but I can confirm that azureus has
been working perfectly for me in fc8 on i386.

That's probably not an awful lot of use as my original bug report was on x86_64.
Sorry, but I don't have that platform available for testing at the present time.

Note You need to log in before you can comment on or make changes to this bug.