Bug 29707 - Sun java 1.3.1beta build 15 dies with segmentation fault
Sun java 1.3.1beta build 15 dies with segmentation fault
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-26 22:04 EST by Need Real Name
Modified: 2016-11-24 10:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 09:21:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-26 22:04:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)


After installing Sun java 1.3.1beta build 15 I request a version string
but get a segmentation fault instead...

Reproducible: Always
Steps to Reproduce:

1. Download and install j2sdk-1_3_1-beta-linux-i386.bin
    from java.sun.com

2. Type:

    java -version

	

Actual Results:  bali% ./java -version

Unexpected Signal : 11 occurred at PC=0x401f3f9c
Function name=start_thread__2osP6Thread
Library=/usr/java1.3.1/jre/lib/i386/client/libjvm.so

Current Java thread:

Expected Results:  kuta% ./java -version
java version "1.3.1-beta"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1-beta-b15)
Java HotSpot(TM) Client VM (build 1.3.1beta-b15, mixed mode)
kuta% 


bali% ./java -version

Unexpected Signal : 11 occurred at PC=0x401f3f9c
Function name=start_thread__2osP6Thread
Library=/usr/java1.3.1/jre/lib/i386/client/libjvm.so

Current Java thread:

zsh: segmentation fault  ./java -version
bali% 
bali% ./java 
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(gdb) run -version
Starting program: /usr/java1.3.1/bin/i386/native_threads/java -version
[New Thread 1024 (LWP 1567)]
[New Thread 2049 (LWP 1577)]
Delayed SIGSTOP caught for LWP 1577.
[New Thread 1026 (LWP 1578)]
Delayed SIGSTOP caught for LWP 1578.
LWP 1578 exited.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 1567)]
0x401f3f9c in os::start_thread () at eval.c:41
41	eval.c: No such file or directory.
	in eval.c
(gdb) 
(gdb) 
(gdb) where
#0  0x401f3f9c in os::start_thread () at eval.c:41
#1  0x40224237 in Threads::create_vm () at eval.c:41
#2  0x401971d8 in JNI_CreateJavaVM () at eval.c:41
#3  0x08049bca in InitializeJVM () at eval.c:41
#4  0x08048fd0 in main () at eval.c:41
#5  0x40444f11 in __libc_start_main (main=0x8048c90 <main>, argc=2,
ubp_av=0xbffff93c, 
    init=0x8048974 <_init>, fini=0x804aaec <_fini>, rtld_fini=0x4000e214
<_dl_fini>, 
    stack_end=0xbffff934) at ../sysdeps/generic/libc-start.c:129
(gdb) 
(gdb) info threads
  3 Thread 1026 (unknown thread_db state 1)  __strtol_internal (nptr=???,
endptr=???, 
    base=???, group=???) at eval.c:36
  2 Thread 2049 (LWP 1577)  0x40500a07 in __poll (fds=0x808d1ac, nfds=1,
timeout=2000)
    at ../sysdeps/unix/sysv/linux/poll.c:63
* 1 Thread 1024 (LWP 1567)  0x401f3f9c in os::start_thread () at eval.c:41
(gdb) 

Linux version 2.4.0-0.99.11 (root@porky.devel.redhat.com) (gcc version 2.96
20000731 (Red Hat Linux 7.0)) #1 Wed Jan 24 16:07:17 EST 2001

bali% ldd -v libjvm.so            
	libnsl.so.1 => /lib/libnsl.so.1 (0x403ee000)
	libdl.so.2 => /lib/libdl.so.2 (0x40404000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x40408000)
	libstdc++-libc6.1-1.so.2 => /usr/lib/libstdc++-libc6.1-1.so.2 (0x4041d000)
	libm.so.6 => /lib/libm.so.6 (0x40460000)
	libc.so.6 => /lib/libc.so.6 (0x40480000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x2aaaa000)

	Version information:
	./libjvm.so:
		libm.so.6 (GLIBC_2.0) => /lib/libm.so.6
		libm.so.6 (GLIBC_2.1) => /lib/libm.so.6
		libdl.so.2 (GLIBC_2.1) => /lib/libdl.so.2
		libdl.so.2 (GLIBC_2.0) => /lib/libdl.so.2
		libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
		libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
		libpthread.so.0 (GLIBC_2.0) => /lib/libpthread.so.0
		libpthread.so.0 (GLIBC_2.1) => /lib/libpthread.so.0
	/lib/libnsl.so.1:
		libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
		libc.so.6 (GLIBC_2.2) => /lib/libc.so.6
		libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
		libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
	/lib/libdl.so.2:
		libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
		libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
		libc.so.6 (GLIBC_2.2) => /lib/libc.so.6
		libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
	/lib/libpthread.so.0:
		libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
		libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
		libc.so.6 (GLIBC_2.2) => /lib/libc.so.6
		libc.so.6 (GLIBC_2.1.2) => /lib/libc.so.6
		libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
	/usr/lib/libstdc++-libc6.1-1.so.2:
		libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
		libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
	/lib/libm.so.6:
		libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
		libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
	/lib/libc.so.6:
		ld-linux.so.2 (GLIBC_2.1.1) => /lib/ld-linux.so.2
		ld-linux.so.2 (GLIBC_2.1) => /lib/ld-linux.so.2
		ld-linux.so.2 (GLIBC_2.2) => /lib/ld-linux.so.2
		ld-linux.so.2 (GLIBC_2.0) => /lib/ld-linux.so.2

bali% cat /etc/redhat-release 
Red Hat Linux release 7.0.90 (Fisher)
Comment 1 Need Real Name 2001-02-26 22:09:06 EST
The JDK is available from:
 
http://developer.java.sun.com/developer/earlyAccess/j2sdk131/
Comment 2 Arjan van de Ven 2001-02-27 08:15:36 EST
is this the bug where sun java assumed something about /proc layout it 
shouldn't assume ?
Comment 3 Johann Muller 2001-05-06 07:42:54 EDT
I have been unable to run jdk1.3.0_02 from sun on a default workstation install
of RH 7.1.
Unfortunately , I cannot give any more information because I had to reinstall RH
7.0.

The JVM worked first time in RH 7.0.

Comment 4 Arjan van de Ven 2001-05-06 08:54:28 EDT
Please read the releasenotes on how to work around the bug in the Sun JVM.
Comment 5 Lutz Foerster 2001-05-25 11:13:28 EDT
If you use/download the Java VM from IBM, then you do not have this Problem. 
Java version 1.3.0 from IBM works on Linux RH v. 7.1

Lutz Foerster
mailto:lfoerst@fuse.net
Comment 6 Need Real Name 2002-04-01 10:00:46 EST
I don't know what it is word I had some problems installing the Sun 
j2sdk-1_3_1_02-linux-i386-rpm.bin on my RedHat 7.1 and 7.0

I fixed it by adding some symlinks in /usr/lib/
On my RedHat 7.0 this was 
ln -s libstdc++-3-libc6.2-2-2.10.0.a    /usr/lib/libstdc++-libc6.1-1.a.2
ln -s libstdc++-3-libc6.2-2-2.10.0.so  /usr/lib/libstdc++-libc6.1-1.so.2

I can't remember if it also did do a segemtation fault.
But it did complain about some missing library.
One of them was libjvm.so, I think because it was a some time ago.

On the RedHat 7.1 I did do the simular thing.
Can't remember the exact symlinks.

At least java seems to run fine on both.
I've ran several programs on the 7.0 without any problems.
Also some on the 7.1.

# /usr/java/jdk1.3.1_02/bin/java -version
java version "1.3.1_02"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1_02-b02)
Java HotSpot(TM) Client VM (build 1.3.1_02-b02, mixed mode)

Hope it helps (not a linux expert)
Rob,
test@comweb.nl










Note You need to log in before you can comment on or make changes to this bug.