Bug 297071 - Xulrunner package conflicts prevent refresh
Xulrunner package conflicts prevent refresh
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-19 18:38 EDT by Carl Preddy
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 23:10:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Preddy 2007-09-19 18:38:01 EDT
Description of problem:
After clean install of F8test2 on 9/17 xulrunner update fails

Version-Release number of selected component (if applicable):


How reproducible:totally


Steps to Reproduce:
1.Install F8test2 for i386, standard repos and no customization
2.yum -y update (with everything else up-to-date) or use pup with "xulrunner
packages" checked
3.
  
Actual results:
[root@chapeau ~]# yum -y update 
Loading "refresh-updatesd" plugin
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libgtkembedmoz.so for package: yelp
--> Processing Dependency: libxpcom_core.so for package: yelp
--> Processing Dependency: gecko-libs = 1.8.1.6 for package: yelp
---> Package xulrunner.i386 0:1.9-0.alpha7.2.fc8 set to be updated
--> Finished Dependency Resolution
Error: Unresolvable requirement gecko-libs = 1.8.1.6 for yelp
Error: Unresolvable requirement libgtkembedmoz.so for yelp
Error: Unresolvable requirement libxpcom_core.so for yelp

Expected results:
install without error

Additional info: For some reason "yum -y update xulrunner" does not find anything.
Comment 1 Stewart Adam 2007-09-30 11:01:50 EDT
This is still present in devel:
# sudo yum install firefox-devel
Loading "presto" plugin
Loading "refresh-updatesd" plugin
Setting up and reading Presto delta metadata
livna-development         100% |=========================| 1.2 kB    00:00     
development               100% |=========================| 1.2 kB    00:00     
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package xulrunner-devel.i386 0:1.9-0.alpha7.2.fc8 set to be updated
--> Processing Dependency: xulrunner = 1.9-0.alpha7.2.fc8 for package:
xulrunner-devel
--> Processing Dependency: libxul.so for package: xulrunner-devel
--> Running transaction check
---> Package xulrunner.i386 0:1.9-0.alpha7.2.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 xulrunner-devel         i386       1.9-0.alpha7.2.fc8  development       3.6 M
Installing for dependencies:
 xulrunner               i386       1.9-0.alpha7.2.fc8  development       9.5 M

Transaction Summary
=============================================================================
Install      2 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 13 M
Is this ok [y/N]: y
Downloading Packages:
Downloading DeltaRPMs:
Rebuilding rpms from deltarpms
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package gnome-python2-gtkmozembed needs libgtkembedmoz.so, this is not available.
Package yelp needs libgtkembedmoz.so, this is not available.
Package yelp needs libxpcom_core.so, this is not available.
Package yelp needs gecko-libs = 1.8.1.6, this is not available.
Package libswt3-gtk2 needs firefox, this is not available.
Package gnome-python2-gtkmozembed needs firefox = 2.0.0.6, this is not available.



Additionally:

# sudo rpm -i xulrunner-1.9-0.alpha7.2.fc8.i386.rpm
        file /etc/gre.d/gre.conf from install of xulrunner-1.9-0.alpha7.2.fc8
conflicts with file from package firefox-2.0.0.6-10.fc8
Comment 2 Stewart Adam 2007-09-30 11:06:16 EDT
I'm sorry, I just realized that the last part is supposed to happen because
xulrunner obsoletes firefox. But then when using rpm -Uhv even more dep errors
occur:

error: Failed dependencies:
        libgtkembedmoz.so is needed by (installed)
gnome-python2-gtkmozembed-2.19.1-5.fc8.i386
        libgtkembedmoz.so is needed by (installed) yelp-2.20.0-1.fc8.i386
        libxpcom_core.so is needed by (installed) yelp-2.20.0-1.fc8.i386
        gecko-libs = 1.8.1.6 is needed by (installed) yelp-2.20.0-1.fc8.i386
        firefox is needed by (installed) libswt3-gtk2-3.3.0-20.fc8.i386
        firefox = 2.0.0.6 is needed by (installed)
gnome-python2-gtkmozembed-2.19.1-5.fc8.i386
Comment 3 Matthias Clasen 2007-10-01 10:42:30 EDT
xulrunner got removed from F8. The easiest fix for any problems caused by the
temporary appearance of xulrunner in rawhide is to just rpm -e xulrunner.

Note You need to log in before you can comment on or make changes to this bug.