Bug 297931 - Problems with install when using raw lvm2 drives
Problems with install when using raw lvm2 drives
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-20 07:13 EDT by Trever Adams
Modified: 2008-08-08 16:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-08 16:14:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2007-09-20 07:13:17 EDT
The installer is setup to detect drives without valid partition tables.
System-config-lvm (I think is what I used) creates drives without partition
tables with raw lvm2 data. I have a drive like this.

At least 3 times I was asked if I wanted to initialize a partition table
(paraphrasing) on this drive and erase all my data.

I do not know if this affects raw soft raid drives or not. However, the
installer should detect if it is a raw lvm2 or soft raid drive and not ask the
question, partition table or not.

This is a serious bug as it could lead to massive data loss if people aren't
paying attention.
Comment 1 Trever Adams 2008-03-28 16:54:10 EDT
This problem still exists. Raw lvm2 drives ask you if you wish to format them in
F9-beta installer. This needs to be fixed. Someone will screw up and do it
sooner or later.
Comment 2 Bug Zapper 2008-05-13 23:15:28 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Trever Adams 2008-07-07 10:35:27 EDT
This bug still existed in the final release of F9. LVM2 drives shouldn't be
detected as empty/unformatted.
Comment 4 Chris Lumens 2008-08-08 16:14:52 EDT
We don't do anything with raw filesystems, LVMs, or RAID members on drives.  anaconda's not at all set up to create or use them - we deal with the default method of having partition tables and partitions, even if it's just one giant partition across the entire disk.  I don't really see what the problem here is - we detect that there's no partition table on the device, and offer the option to either create a new partition table or ignore the device and keep going.

People should be paying attention, since they are doing an install of an operating system.  That's an inherently risky and complicated operation that requires attention.  Given that we are not going to work on making use of raw devices, it seems only normal that we are detecting the presence of disks without partitions and giving you the opportunity to do something about them or ignore them.
Comment 5 Trever Adams 2008-08-08 16:49:34 EDT
Your position may be accurate for anaconda. It isn't for system-config-* stuff. That is how that LVM drive was created. I am sorry if my using the recommended tools was wrong, maybe documentation should be updated and the system-config-* stuff changed so it cannot do unsupported operations.
Comment 6 Chris Lumens 2008-08-08 16:52:53 EDT
Perhaps we should open a bug with system-config-lvm then to get them making logical volumes on partitions instead of the raw device.

Note You need to log in before you can comment on or make changes to this bug.