Bug 29808 - LILO not installed
LILO not installed
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-27 13:39 EST by Sawan Vithlani
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 14:17:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sawan Vithlani 2001-02-27 13:39:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)


i installed redhat 7.0 a a Pentiunm II 400 MHz machine with 128 MB of 
memory. I have Windows NT on the same disk but on other partiitons. I had 
Red Hat 5.2 befor so I fdisk /MBRd it an dremoved completely. I chose a 
custom install for 7.0 and chose to install LILO in the first sector 
of /boot. After completing installation and creation of the boot disk the 
machine rebooted but went into NT directly. It booted fine with the boot 
disk. Tried the exact procedure on another machine [Pentium III, 400 MHz, 
128 Mb memory] and it was the same. No LILO, only NT and boot disk works 
fine.

Reproducible: Always
Steps to Reproduce:
1.Fdisk /MBR the existing Linux verison [5.2 in my case],
2.Partition disks [/ 1.7gb, /boot 20 MB, swap 64 MB],
3.Install verison 7.0, choosing a custom install,
4.Install all components except the various servers.
	

Actual Results:  After the machine was rebooted LILO was not present i.e. 
Windows NT boot options were presented.

Expected Results:  LILO should have been installed and should have 
presented an option to boot either NT or Red Hat Linux 7.0.
Comment 1 Sawan Vithlani 2001-02-28 09:33:02 EST
I checked and the LILO program is PRESENT on the system in the correct 
directories. The RPM verification shows no problems. I tried uninstalling the 
RPM and installing it again but no change.
Comment 2 Brent Fox 2001-02-28 21:36:17 EST
We have not seen this issue internally.  Are you sure that you selected to
install LILO to the MBR in the installer?  After installation, can you run the
lilo command and does it then write itself to the MBR?
Comment 3 Sawan Vithlani 2001-03-01 12:25:43 EST
Yes I can run the LILO program after and it saya "wrote linux, wrote nt". And
yet nothing happens. I still have to boot using a floppy. The same for the
second machine on whwich I installed.

Thank you.
Comment 4 Brent Fox 2001-03-01 14:17:13 EST
Can you attach your lilo.conf file?  That would be helpful.
Comment 5 Sawan Vithlani 2001-03-02 08:22:28 EST
I solved the problem. It seems that during installation the lilo.conf file had been written as "boot=/dev/hda8"
 instead of just "boot=/dev/hda". Removing the "8" from the "boot=/dev/hda8" solves the problem. Although I still dont understand why this mistake 
happened  during the installation.

Anyways, thank you very much and sorry for the waste of time.

Note You need to log in before you can comment on or make changes to this bug.