Bug 29829 - Lot of lines in log for my Tekram SCSI
Lot of lines in log for my Tekram SCSI
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-27 15:46 EST by LENHOF
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-07 14:45:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description LENHOF 2001-02-27 15:46:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [fr] (X11; U; Linux 2.4.1-0.1.9 i686)


I think that need some further looking (I installed it monday or something
like this)

[root@mylinux /root]# ll /var/log/messages 
-rw-------    1 root     root     71738140 fiv 27 21:40 /var/log/messages
[root@mylinux /root]# 

Loading part...
Feb 26 06:18:14 mylinux kernel: SCSI subsystem driver Revision: 1.00
Feb 26 06:18:14 mylinux kernel: kmod: failed to exec /sbin/modprobe -s -k
scsi_hostadapter, errno = 2
Feb 26 06:18:14 mylinux kernel: sym53c8xx: at PCI bus 0, device 9, function
0
Feb 26 06:18:14 mylinux kernel: sym53c8xx: setting
PCI_COMMAND_PARITY...(fix-up)Feb 26 06:18:14 mylinux kernel: sym53c8xx:
53c875E detected with Tekram NVRAM
Feb 26 06:18:14 mylinux kernel: sym53c875E-0: rev 0x26 on pci bus 0 device
9 function 0 irq 9
Feb 26 06:18:14 mylinux kernel: sym53c875E-0: Tekram format NVRAM, ID 7,
Fast-20
, Parity Checking
Feb 26 06:18:14 mylinux kernel: sym53c875E-0: on-chip RAM at 0xde000000
Feb 26 06:18:14 mylinux kernel: sym53c875E-0: restart (scsi reset).
Feb 26 06:18:14 mylinux kernel: sym53c875E-0: Downloading SCSI SCRIPTS.
Feb 26 06:18:14 mylinux kernel: scsi0 : sym53c8xx - version 1.6b
Feb 26 06:18:14 mylinux kernel:   Vendor: TEAC      Model:
CD-R58S           Rev: 1.0K
Feb 26 06:18:14 mylinux kernel:   Type:  
CD-ROM                             ANSI SCSI revision: 02
Feb 26 06:18:14 mylinux kernel: VFS: Mounted root (ext2 filesystem)
readonly.
....

And the lines I found every 2 seconds :

Feb 26 06:26:56 mylinux kernel: sym53c875E-0-<3,0>: sync: per=25
scntl3=0x30 scntl4=0x0 ofs=15 fak=0 chg=0.
Feb 26 06:26:56 mylinux kernel: sym53c875E-0-<3,0>: sync msgout:
1-3-1-c-10.
Feb 26 06:26:56 mylinux kernel: sym53c875E-0-<3,0>: sync msg in:
1-3-1-19-f.
Feb 26 06:26:56 mylinux kernel: sym53c875E-0-<3,0>: sync: per=25
scntl3=0x30 scntl4=0x0 ofs=15 fak=0 chg=0.
Feb 26 06:26:56 mylinux kernel: sym53c875E-0-<3,0>: sync msgout:
1-3-1-c-10.
Feb 26 06:26:56 mylinux kernel: sym53c875E-0-<3,0>: sync msg in:
1-3-1-19-f.
Feb 26 06:26:56 mylinux kernel: sym53c875E-0-<3,0>: sync: per=25
scntl3=0x30 scntl4=0x0 ofs=15 fak=0 chg=0.
Feb 26 06:26:56 mylinux kernel: sym53c875E-0-<3,0>: sync msgout:
1-3-1-c-10.
Feb 26 06:26:56 mylinux kernel: sym53c875E-0-<3,0>: sync msg in:
1-3-1-19-f.
Feb 26 06:26:56 mylinux kernel: sym53c875E-0-<3,0>: sync: per=25
scntl3=0x30 scntl4=0x0 ofs=15 fak=0 chg=0.
Feb 26 06:26:56 mylinux kernel: sym53c875E-0-<3,0>: sync msgout:
1-3-1-c-10.
Feb 26 06:26:56 mylinux kernel: sym53c875E-0-<3,0>: sync msg in:
1-3-1-19-f.
Feb 26 06:26:56 mylinux kernel: sym53c875E-0-<3,0>: sync: per=25
scntl3=0x30 scntl4=0x0 ofs=15 fak=0 chg=0.
Feb 26 06:26:57 mylinux kernel: [drm:r128_do_wait_for_fifo] *ERROR*
r128_do_wait_for_fifo failed!
Feb 26 06:26:58 mylinux kernel: sym53c875E-0-<3,0>: sync msgout:
1-3-1-c-10.
Feb 26 06:26:58 mylinux kernel: sym53c875E-0-<3,0>: sync msg in:
1-3-1-19-f.
Feb 26 06:26:58 mylinux kernel: sym53c875E-0-<3,0>: sync: per=25
scntl3=0x30 scntl4=0x0 ofs=15 fak=0 chg=0.
Feb 26 06:26:58 mylinux kernel: sym53c875E-0-<3,0>: sync msgout:
1-3-1-c-10.
Feb 26 06:26:58 mylinux kernel: sym53c875E-0-<3,0>: sync msg in:
1-3-1-19-f.
Feb 26 06:26:58 mylinux kernel: sym53c875E-0-<3,0>: sync: per=25
scntl3=0x30 scntl4=0x0 ofs=15 fak=0 chg=0.
Feb 26 06:26:58 mylinux kernel: sym53c875E-0-<3,0>: sync msgout:
1-3-1-c-10.
Feb 26 06:26:58 mylinux kernel: sym53c875E-0-<3,0>: sync msg in:
1-3-1-19-f.
Feb 26 06:26:58 mylinux kernel: sym53c875E-0-<3,0>: sync: per=25
scntl3=0x30 scntl4=0x0 ofs=15 fak=0 chg=0.
Feb 26 06:26:58 mylinux kernel: sym53c875E-0-<3,0>: sync msgout:
1-3-1-c-10.
Feb 26 06:26:58 mylinux kernel: sym53c875E-0-<3,0>: sync msg in:
1-3-1-19-f.



Reproducible: Always
Steps to Reproduce:
1.Starting linux....
2.
3.
	

Actual Results:  Too much lines in /var/log/messages...
The CD Writer seems usable (I've only test reading for now)

Probably something wrong in the driver ?
Comment 1 Michael K. Johnson 2001-03-01 00:05:08 EST
Doug, can you please analyze this?
Comment 2 Doug Ledford 2001-03-02 03:44:28 EST
This is something Gerard will probably have to look at.  Basically, the driver
is renegotiating the transfer rate with the CD-ROM an inordinately large number
of times, and it is logging those negotiations.  Normally, those aren't logged,
so I'm not sure what's up with that.  I'll look into the kernel config files to
see if there is anything in there that could be causing this as well.  Nothing
in the config files looked like it would cause this to me...time to email
Gerard...
Comment 3 LENHOF 2001-03-07 04:50:08 EST
Hi

Tried to burn two cd of wolfverine with the burner attached on my tekram just
seem to work but doing after burning md5sum /dev/cdrom on the CDs give me bad
results.... I will try to install RH7 again and make a new try to see if it
works better with kernel 2.2...

PS : My Burner is a TEAC CD 58s

Regards
JYL
Comment 4 LENHOF 2001-03-07 05:22:25 EST
Just want to add that my Motherboard is a k7v with an Athlon.... because I know
that a lot of bug seems to be linked to the VIA chip...

Just my 2 cents
Comment 5 Doug Ledford 2001-03-07 14:45:50 EST
I've got confirmation that the problem with the log files was simply that a
debug flag was turned on in the driver.  The reason for renegotiating every two
seconds is likely magicdev or some other program checking the CD-ROM to see if
it has a CD in it every two seconds, and the check resulting in a
CHECK_CONDITION return from the CD-ROM, which signals a need to renegotiate
speed settings in the driver.  This has been resolved by the latest sym/ncr
driver pair which is currently undergoing final QA at Symbios and then will be
released via Gerard to the mainstream linux kernel.  Hence, it will be resolved
shortly.  Since the driver maintainer is taking care of this (and since I
checked our internal tree and I can't see where the debug flag is still being
set), I'm closing this as wontfix and waiting for the driver update to come
through.  In the meantime, you can load your sym53c8xx module with the option
sym53c8xx=debug:0 to disable the debug messages.
Comment 6 Doug Ledford 2001-03-07 14:49:08 EST
I was wrong.  A patch to our tree to disable the message has already been sent
through by Pam Delaney and integrated into our CVS tree, so I'm going to close
this as resolved/RAWHIDE instead.
Comment 7 Andy Wang 2001-04-26 22:29:18 EDT
Was this reported against wolverine or seawolf?  It looks like it was
wolverine.  If that's the case will this fix be released in an errata update? 
(I hope so).
Thanks

Note You need to log in before you can comment on or make changes to this bug.