Bug 298451 - jsvc should warn about exec with absolute/relative path requirement
jsvc should warn about exec with absolute/relative path requirement
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jakarta-commons-daemon (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Permaine Cheung
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-20 11:41 EDT by James Ralston
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 10:40:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to return a userful error message if absolute/relative path not used (847 bytes, patch)
2007-09-20 11:44 EDT, James Ralston
no flags Details | Diff

  None (edit)
Description James Ralston 2007-09-20 11:41:25 EDT
Because jsvc calls execve() on Linux platforms, if jsvc is invoked by allowing
it to be found in the PATH, the execve() call will fail unless the CWD just so
happens to be where the jsvc binary is located.

Thus, jsvc needs to be invoked with an absolute or relative path.  However, jsvc
makes no attempt whatsoever to detect if it was invoked via an absolute/relative
path and return an appropriate error.  Catching this error isn't difficult; jsvc
simply needs to check for the absence of a '/' character in argv[0].
Comment 1 James Ralston 2007-09-20 11:44:06 EDT
Created attachment 200851 [details]
patch to return a userful error message if absolute/relative path not used

With this patch, jsvc will detect if it wasn't invoked with an absolute or
relative path, and return a useful error message.
Comment 2 Permaine Cheung 2007-09-25 10:40:37 EDT
Built in rawhide.

Note You need to log in before you can comment on or make changes to this bug.