Bug 298581 - NForce4 (ECS Elitegroup MB)Clock runs twice as fast as normal
NForce4 (ECS Elitegroup MB)Clock runs twice as fast as normal
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-20 12:56 EDT by David R. Fischer
Modified: 2008-01-03 18:29 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.23.1-10.fc7PAE
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-03 18:29:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vv (15.81 KB, text/plain)
2007-09-20 12:59 EDT, David R. Fischer
no flags Details
cat /proc/interrupts (534 bytes, text/plain)
2007-09-20 13:01 EDT, David R. Fischer
no flags Details
dmidecode (14.50 KB, text/plain)
2007-09-20 13:02 EDT, David R. Fischer
no flags Details
Dmesg with disable_8254_timer (19.22 KB, text/plain)
2007-09-20 16:09 EDT, David R. Fischer
no flags Details
boot with nohz and highres off still no good clock still running fast (19.43 KB, text/plain)
2007-09-20 18:37 EDT, David R. Fischer
no flags Details
boot with clocksource - still fast clock (19.47 KB, text/plain)
2007-09-20 18:41 EDT, David R. Fischer
no flags Details

  None (edit)
Description David R. Fischer 2007-09-20 12:56:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.5) Gecko/20070718 Fedora/2.0.0.5-1.fc7 Firefox/2.0.0.5

Description of problem:
When booting the latest kernel 2.6.22.5-76 on my ECS Elitegroup motherboard the clock runs at about 2X the normal speed.  I have tried 'no_timer_check' and 'noapic' with no good results.  I have updated the BIOS to the latest provided by the mfg.

Version-Release number of selected component (if applicable):
kernel-2.6.22.5-76/fc7

How reproducible:
Always


Steps to Reproduce:
1.boot kernel
2. do 'date' command several times to check time 
3.

Actual Results:
time jumps between 2-7 seconds each time

Expected Results:
seconds should move normaly

Additional info:
Comment 1 David R. Fischer 2007-09-20 12:59:57 EDT
Created attachment 200971 [details]
lspci -vv
Comment 2 David R. Fischer 2007-09-20 13:01:18 EDT
Created attachment 200981 [details]
cat /proc/interrupts
Comment 3 David R. Fischer 2007-09-20 13:02:28 EDT
Created attachment 200991 [details]
dmidecode
Comment 4 Chuck Ebbert 2007-09-20 14:48:37 EDT
Please post /var/log/dmesg

And try boot options:

  disable_timer_pin_1

or

  disable_8254_timer
Comment 5 David R. Fischer 2007-09-20 16:09:27 EDT
Created attachment 201271 [details]
Dmesg with disable_8254_timer

When I did the disable_timer_pin_1 the system would not even boot
Comment 6 David R. Fischer 2007-09-20 16:21:03 EDT
Comment on attachment 201271 [details]
Dmesg with disable_8254_timer

Time not fixed
Comment 7 David R. Fischer 2007-09-20 16:43:30 EDT
last messages on the boot with 'disable_timer_pin_1' is:

Loading keyring
- Added public key 4A67DBB026B0246B
- User ID: Red Hat, Inc. (Kernel Module GPG key)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)

this is with kernel opts: disable_timer_pin_1 vga=ask boot_delay=30 earlyprintk=vga'
Comment 8 Chuck Ebbert 2007-09-20 17:51:09 EDT
Please try:

   nohz=off highres=off

and/or

   clocksource=acpi_pm

Comment 9 David R. Fischer 2007-09-20 18:37:03 EDT
Created attachment 201441 [details]
boot with nohz and highres off still no good clock still running fast
Comment 10 David R. Fischer 2007-09-20 18:41:24 EDT
Created attachment 201461 [details]
boot with clocksource - still fast clock
Comment 11 David R. Fischer 2007-09-20 18:43:30 EDT
I am able to boot into kernel 2.6.18-1.2798.fc6 and not have the clock issue.  I
also can boot into the XEN kernel and the clock works fine.
Comment 12 David R. Fischer 2007-09-24 12:08:11 EDT
even with older kernel 2.6.18-1.2798.fc6 I am getting syslog entries about
Kernel sync time 
Sep 24 07:55:46 rio ntpd[2045]: kernel time sync error 0001

I will be trying to go back to Xen kernel but really don't want to run a Xen kernel
Comment 13 Chuck Ebbert 2007-09-24 19:40:49 EDT
More things to try:

  apicmaintimer nohz=off highres=off
  noapictimer nohz=off highres=off

Comment 14 Christopher Brown 2007-10-03 11:34:51 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

Have you been able to test the parameters above with the latest kernel?
Comment 15 Rob Ristroph 2007-11-01 13:49:18 EDT
I am also seeing this problem.  I have an ECS (Elitegroup) GeForce 6100SM-M
motherboard and an  "AMD Athlon(tm) X2 Dual Core Processor BE-2300" (that's from
/proc/cpuinfo).

I discovered that the boot option "nosmp" will fix the problem.  I have tried
some other boot options from various web searches, but not all the ones listed
above.  I tried "clock=pit", "noapic", "nolapic", "no_timer_check".

This is my uname -a:

Linux juliet 2.6.23.1-10.fc7 #1 SMP Fri Oct 19 15:39:08 EDT 2007 i686 athlon
i386 GNU/Linux

I would really like to get this fixed as I am running with just half the CPU
until it is.  If there is anything I can do to help let me know.  

Comment 16 Chuck Ebbert 2007-11-01 13:53:28 EDT
There is now a common problems page with additional workarounds:

https://fedoraproject.org/wiki/KernelCommonProblems
Comment 17 Rob Ristroph 2007-11-01 15:30:15 EDT
I tried "nohz=off highres=off", and then also "clocksource=acpi_pm", and these
did not fix the problem.  Perhaps that KernelCommonProblems page should be
updated to indicate that those fixes don't work in all cases ?
Comment 18 Christopher Brown 2007-12-12 20:04:21 EST
Rob,

What is the latest on this? I've seen a few posts with this issue and as you
have said - various boot flags seem to work in some instances. Any progress?
Have you tried:

noapic acpi=off
Comment 19 Rob Ristroph 2007-12-13 21:51:19 EST
I am running with kernel 2.6.23.1-10.fc7PAE with no special kernel arguments,
and it works (i.e., clock runs at normal speed even with both processors working).

I think I did something additional, such as a BIOS setting or something, but I
cannot remember what it was.  I took notes at the time but I don't have access
to them.  If I can get access there next week and figure out what it was, I will
post here.
Comment 20 Christopher Brown 2008-01-03 18:29:46 EST
Okay, thanks for the feedback. I'm closing this CURRENT_RELEASE as per your
comments but the original reporter can re-open if he needs to.

Note You need to log in before you can comment on or make changes to this bug.