This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 299531 - upstream no longer updates microcode in the tarball
upstream no longer updates microcode in the tarball
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: microcode_ctl (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jon Masters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-20 19:57 EDT by Dave Jones
Modified: 2015-01-04 17:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-29 15:19:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2007-09-20 19:57:27 EDT
Whilst we have the latest microcode_ctl tarball, upstream has stopped rerolling
the tarballs just because the microcode data has been updated.
We need to periodically grab the latest from http://www.urbanmyth.org/microcode/
and include it seperately in the RPM from now on.

(Even better would be to also include a 'update-microcode' script that would try
to grab the latest, but this would require coordinating with upstream so that
there's a predictable URL for the script to grab from.  Maybe we can talk them
into adding a symlink that always points to the latest)
Comment 1 Dave Jones 2008-01-17 14:08:38 EST
There's a predictable url now. 
http://www.urbanmyth.org/microcode/microcode-latest.dat.bz2
Comment 2 Bradley 2008-03-26 02:12:21 EDT
Its now downloadable directly from intel. From the urbanmyth site:

"*** Intel are now distributing the microcode to the wider community ***

A lot has happened in the last 7 years, and now with more OSs and CPUs to
support Intel have decided to make their microcode datafiles available for
general download on their main Download center and as there isn't any point in
multiple points of distribution we'll not be making updated datafiles available
anymore!

To get the datafile, you now have to go to
http://downloadcenter.intel.com/default.aspx select processors, select the CPU
you're interested in, go to Linux as the OS and download from there. You can
setup an RSS feed if you're interested too.

Anyway, there you go!

-Simon"
Comment 3 Dave Jones 2008-03-29 15:10:02 EDT
nggh.  what a pain. Intel have set up possibly the worst case scenario wrt
automatic updates.  This site a) needs javascript enabled before it lets you
download.  b) uses unpredictable filenames. and c) seems to move stuff around
every so often.

I think we're just going to have to manually download the latest periodically,
and throw it into the rpm by hand.

Note You need to log in before you can comment on or make changes to this bug.