Bug 299541 - Dual head settings not settable in xorg.conf (or dwmw2 too stupid to work out how)
Dual head settings not settable in xorg.conf (or dwmw2 too stupid to work out...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-20 20:12 EDT by David Woodhouse
Modified: 2008-05-06 03:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 03:05:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.74 KB, application/octet-stream)
2007-09-20 20:12 EDT, David Woodhouse
no flags Details
Log with working ati driver. (65.50 KB, text/plain)
2007-09-20 20:13 EDT, David Woodhouse
no flags Details
Log with new ati driver. (78.99 KB, text/plain)
2007-09-20 20:14 EDT, David Woodhouse
no flags Details
xorg.conf that works with the xorg ati drivers (1.68 KB, application/octet-stream)
2008-01-03 14:26 EST, Sean Bruno
no flags Details

  None (edit)
Description David Woodhouse 2007-09-20 20:12:49 EDT
In Fedora 7, my dual-head config with Radeon 9600 worked perfectly -- 1920x1200
on the primary DVI head, 1600x1200 on the VGA secondary.

After upgrading to rawhide, only the second monitor is used. Reverting only the
xorg-x11-drv-ati package to the Fedora 7 version (6.6.3-2.fc7) fixes this
regression.
Comment 1 David Woodhouse 2007-09-20 20:12:49 EDT
Created attachment 201521 [details]
xorg.conf
Comment 2 David Woodhouse 2007-09-20 20:13:43 EDT
Created attachment 201531 [details]
Log with working ati driver.
Comment 3 David Woodhouse 2007-09-20 20:14:29 EDT
Created attachment 201541 [details]
Log with new ati driver.
Comment 4 David Woodhouse 2007-09-20 20:15:53 EDT
Hm...

(WW) RADEON(0): Option "MergedFb" is not used
Comment 5 David Woodhouse 2007-09-20 20:40:41 EDT
Attempts to use Xinerama have so far failed....

(II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message.

Backtrace:
0: X(xf86SigHandler+0x94) [0x10092c34]
1: [0x100364]
2: [0x10251058]
3: [0x3003540]
4: X(xf86CrtcScreenInit+0xd8) [0x100c4f88]
5: /usr/lib/xorg/modules/drivers//radeon_drv.so(RADEONScreenInit+0x16d4) [0xf83b324]
6: X(AddScreen+0x21c) [0x10027e8c]
7: X(InitOutput+0x290) [0x10065c20]
8: X(main+0x278) [0x10028678]
9: /lib/libc.so.6 [0xfbf104c]
10: /lib/libc.so.6 [0xfbf121c]

Fatal server error:
Caught signal 11.  Server aborting
Comment 6 Dave Airlie 2007-09-20 20:42:51 EDT
You don't need any of the xinerama or mergedfb stuff any more..

In theory the xrandr utility should be able to set modes on both your monitors...

you might try removing the reverseddc as well as I think we should detect that..
Comment 7 David Woodhouse 2007-09-20 21:05:05 EDT
Ah, Ok. First I must run 'xrandr --auto' repeatedly, until it stops complaining
that it can't find a crtc for DVI-0 and actually turns it on. That takes 2-3
attempts.

After that, I can run 'xrandr --output DVI-0 --left-of VGA-0' and it works.

Is there any way to get this to happen automatically when the X server starts up?
Comment 8 David Woodhouse 2007-09-20 21:18:39 EDT
Updating to xorg-x11-drv-ati-6.7.193-1.fc8 fixes most of this -- I get clone
mode on both screens at startup, and I can run 'xrandr --output DVI-0 --left-of
VGA-0' to get the desired setup.

Now I need to work out how to put this into xorg.conf....
Comment 9 Matěj Cepl 2007-09-21 08:32:30 EDT
I am not sure about the status of this bug -- is it broken, or dwmw2 tried to do
things obsolete way?
Comment 10 David Woodhouse 2007-09-21 08:39:02 EDT
It _was_ broken, but the latest package in rawhide seems to fix that.

I tried to do things an obsolete way -- which in my defence was the only way it
would work in F7, but anyone who had the wit to make it work there should also
have the wit to make it work again now, so I'm not going to claim that we're
breaking existing setups.

My only remaining problem is that I have to run that xrandr command after
logging in -- I don't know how to get the X server to do it automatically. It
starts up in clone mode, instead of having the DVI screen 'left of' the VGA.

I'm also not convinced that system-config-display is doing the right thing with
its 'dual head' stuff any more. That should be filed as a separate bug though, I
suppose.
Comment 11 Matěj Cepl 2007-09-21 11:36:13 EDT
Workaround would be to use gnome-session-properties and make the proper calling
of xrandr into Startup Programs.
Comment 12 David Woodhouse 2007-09-21 11:49:32 EDT
Yeah. What I actually did was stick it in /etc/gdm/Init/Default, so it's done
before the GNOME session starts up and I don't have two copies of the login screen .

Not ideal though -- and 'X -query foohost' still won't work right. Surely there
_is_ a way to make this happen from xorg.conf, right?
Comment 13 Gordon Messmer 2007-10-06 23:25:45 EDT
I'm also displeased with this regression.  In the last release it was possible
to specify the layout of multiple monitors on multi-head radeons.  In fact, I
think there were two different ways... MergeFB and by using multiple Device
sections which specified different Screen resources.  I can no longer get either
of those methods to work.
Comment 14 Callum Lerwick 2007-11-28 17:20:46 EST
I'm running into this too. Seems to me, with this change the multihead stuff in
system-config-display can go away, and gnome-display-properties needs to grow
full xrandr 1.2 support instead. I'm a bit surprised this didn't get done before
F8 release.
Comment 15 Sean Bruno 2008-01-03 14:26:44 EST
Created attachment 290766 [details]
xorg.conf that works with the xorg ati drivers
Comment 16 Sean Bruno 2008-01-03 14:27:42 EST
I too have run into this issue.  I also had to revert my xorg-ati driver to the
F7 version to get dual head to work with Xinerama.
Comment 17 Charles R. Anderson 2008-01-22 00:06:35 EST
The key differences between xrandr-based multi-head and traditional
multi-head/Xinerama are that you only use a single Screen in your ServerLayout
section:

Section "ServerLayout"
        Identifier     "new dual-head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Then refer to multiple monitors in the Device section.  Here the
format is Option "Monitor-<actual-monitor-id-from-xrandr>" "<monitor-identifier>"

Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
        Option      "Monitor-DVI-0" "first"
        Option      "Monitor-DVI-1" "second"
EndSection

Then specify the multiple Monitor sections themselves, using the
monitor-identifiers specified above, with the placement options
RightOf or LeftOf:

Section "Monitor"
        Identifier  "first"
EndSection

Section "Monitor"
        Identifier  "second"
        Option      "RightOf" "first"
EndSection

And then of course the single screen section.  Note that you MUST
specify the Virtual resolution as the sum of the resolutions of the
multiple monitors you want to use (either horizontally or vertically,
depending on your preferred monitor orientation).  So below I have
specified Virtual 3200 1200 so that I can place two 1600x1200 monitors
side-by-side.  The Monitor "first" is there just to satisfy the
requirement for a Monitor to be specified--you don't put both monitors
here.

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "first"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Virtual 3200 1200
                Depth     24
                Modes    "1600x1200" "1600x1024" "1440x900" "1400x1050"
"1360x768" "1280x1024"
+"1280x960" "1280x800" "1280x720" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection
Comment 18 David Woodhouse 2008-01-22 06:02:57 EST
Oooh, shiny. Thankyou. I'll test that when I get home in a couple of weeks' time.
Comment 19 Gordon Messmer 2008-02-04 22:51:35 EST
Works for me, even with no "Monitor" line in the Screen section.

I wonder if there's any hope that system-config-display will support xrandr
multi-screen layouts...
Comment 20 Matěj Cepl 2008-02-06 04:00:57 EST
(In reply to comment #19)
> I wonder if there's any hope that system-config-display will support xrandr
> multi-screen layouts...

No, there is a hope that s-c-d will go away and will be replaced by xrandr.
Comment 21 Thomas J. Baker 2008-04-07 22:35:08 EDT
Anyone know where this is this all documented? How would I rotate my second
monitor so instead of being 1600x1200, it's 1200x1600? 
Comment 22 Charles R. Anderson 2008-04-07 22:37:30 EDT
In rawhide at least, it is documented in the xorg.conf(5) man page.
Comment 23 Thomas J. Baker 2008-04-08 10:03:31 EDT
I'm close to having my setupsp working but I can't get the monitors to be of
different resolutions. I've got one that is 1920x1200 and the other is
1600x1200. I've tried having no modes, preferredmodes in each monitor
definition, just one, or the other, and I've had no luck. I've got a

05:00.0 VGA compatible controller: ATI Technologies Inc RV370 [Sapphire X550
Silent] (prog-if 00 [VGA controller])
05:00.1 Display controller: ATI Technologies Inc RV370 secondary [Sapphire X550
Silent]

Also, compiz starts but the right side of the screen is garbled and when I try
to start it with compiz-manager, it complains that the resolution (3840x1200) is
larger than the maximum texture size (2048). This is a 256MB card so is this a
driver limitation?
Comment 24 Charles R. Anderson 2008-04-08 10:24:32 EDT
The maximum texture size is a limitation of the hardware.
Comment 25 Dave Airlie 2008-05-06 03:05:58 EDT
I think I've fixed the original bug reported. damn the me-toos and others to
opening new bugs.

Note You need to log in before you can comment on or make changes to this bug.