Bug 29969 - Internal compiler error in
Summary: Internal compiler error in
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL: http://www.cs.ualberta.ca/~pengzhao/g...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-28 03:56 UTC by Peng Zhao
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-28 03:59:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
it contains the lra.cxx, lra.ii, lra.S and the error message (1.10 MB, text/plain)
2001-02-28 03:59 UTC, Peng Zhao
no flags Details

Description Peng Zhao 2001-02-28 03:56:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (X11; U; Linux 2.2.16-3 i686)


../../be/cg/lra.cxx: In function `void Print_Avail_Set (BB *)':
../../be/cg/lra.cxx:461: Internal compiler error in 
print_operand_address, at config/i386/i386.c:3404
Please submit a full bug report.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.
gmake: *** [lra.o] Error 1

I have no any idea.

Reproducible: Always
Steps to Reproduce:
1.g++ -D_SGI_SOURCE -D_LANGUAGE_C_PLUS_PLUS -funsigned-char
-D__GNU_BUG_WORKAROUND -D_NOTHREADS -c            -Dsgi -DBACK_END
-DMONGOOSE_BE -Dlonglong -D_LONGLONG -D_SVR4_SOURCE -LANG:packed=on
-D__MIPS_AND_IA64_ELF_H -I. -I../../be/cg -I../../be/cg/gra_mon
-I../../be/cg/ia64 -I../../common/com -I../../common/com/ia64
-I../../common/util -I../../common/stl -I../../be/com -I../../be/region
-I../../be/prompf_anl -I../../be/opt -I../../common/targ_info/access
-I../targ_info -I../be -I../include/libelf -fPIC -DTARG_IA64 
-fwritable-strings  -I../include  -O0 -D_MIPSEL -D_LONGLONG
-D_MIPS_SZINT=32 -D_MIPS_SZPTR=32 -D_MIPS_SZLONG=32 -MD ../../be/cg/lra.cxx
-o lra.o
2. Error generated
3.
	

Actual Results:  g++ -D_SGI_SOURCE -D_LANGUAGE_C_PLUS_PLUS -funsigned-char
-D__GNU_BUG_WORKAROUND -D_NOTHREADS -c            -Dsgi -DBACK_END
-DMONGOOSE_BE -Dlonglong -D_LONGLONG -D_SVR4_SOURCE -LANG:packed=on
-D__MIPS_AND_IA64_ELF_H -I. -I../../be/cg -I../../be/cg/gra_mon
-I../../be/cg/ia64 -I../../common/com -I../../common/com/ia64
-I../../common/util -I../../common/stl -I../../be/com -I../../be/region
-I../../be/prompf_anl -I../../be/opt -I../../common/targ_info/access
-I../targ_info -I../be -I../include/libelf -fPIC -DTARG_IA64 
-fwritable-strings  -I../include  -O0 -D_MIPSEL -D_LONGLONG
-D_MIPS_SZINT=32 -D_MIPS_SZPTR=32 -D_MIPS_SZLONG=32 -MD ../../be/cg/lra.cxx
-o lra.o
../../be/cg/lra.cxx: In function `void Print_Avail_Set (BB *)':
../../be/cg/lra.cxx:461: Internal compiler error in 
print_operand_address, at config/i386/i386.c:3404
Please submit a full bug report.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.
gmake: *** [lra.o] Error 1
gmake: Leaving directory
`/compsci/brule12/grad/pengzhao/pro64/osprey1.0/targia32_ia64_nodebug/cg'


Expected Results:  I get the lra.o peacefully

Please check http://www.cs.ualberta.ca/~pengzhao/gcc-err.tar
The tarball contains the lra.cxx, lra.ii, lra.S and the error messages.
==========================
following is my configuration.

[pengzhao@sakwatamau ~]$ uname -a
Linux sakwatamau 2.2.16-3 #17 Tue Nov 28 11:36:11 MST 2000 i686 unknown

[pengzhao@sakwatamau ~]$ rpm -qa |grep gcc
106:gcc-c++-2.96-54
107:gcc-2.96-54

[pengzhao@sakwatamau ~]$ gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.0)


[pengzhao@sakwatamau ~]$ gmake -v
GNU Make version 3.78.1, by Richard Stallman and Roland McGrath.
Built for i386-redhat-linux-gnu
Copyright (C) 1988, 89, 90,91, 92, 93, 94, 95, 96, 97, 98, 99
        Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.

Report bugs to <bug-make@gnu.org>.

Comment 1 Peng Zhao 2001-02-28 03:59:03 UTC
Created attachment 11300 [details]
it contains the lra.cxx, lra.ii, lra.S and the error message

Comment 2 Jakub Jelinek 2001-02-28 15:42:08 UTC
This is fixed since gcc-c++-2.96-64 or -65, not sure which one, at least I can
reproduce it with older gcc's and not with the -65 and up.

Comment 3 Peng Zhao 2001-03-01 01:03:00 UTC
Thank you very much for your guide.

Can you tell me where I can find the bug-listoand patch list of gcc (for various
versions since 2.91)?


Note You need to log in before you can comment on or make changes to this bug.