Bug 299861 - Package removals via rhn_check fail if there are dependencies
Package removals via rhn_check fail if there are dependencies
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.5
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Matthews
Jan Hutař
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-21 05:13 EDT by Martin Poole
Modified: 2010-10-22 14:51 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0771
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 16:05:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Poole 2007-09-21 05:13:29 EDT
Description of problem:

If you schedule a package removal via satellite/rhn and the package has
dependents the removal will fail.

Version-Release number of selected component (if applicable):

up2date-4.4.69-15

How reproducible:

Always.

Steps to Reproduce:
1.Install a package that pulls in dependencies
   (amanda-client, requires amanda)
2.schedule removal of amanda
3.
  
Actual results:

Client execution returned "RPM dependency error. The message was: Dependencies
should have already been resolved, but they are not." (code 14)
Packages to be removed:

    * amanda-2.4.4p3-1

Dependency errors encountered:

    * amanda-client-2.4.4p3-1 requires libamanda-2.4.4p3.so
    * amanda-client-2.4.4p3-1 requires amanda-2.4.4p3


Expected results:

Action should succeed, listing removed dependents.

Additional info:

this also fails under RHEL3 with

  Client execution returned "Fatal error in Python code occured [[6]]" (code -1)

but since RHEL3 is in maintenance I have not replicated this bug for it.
Comment 1 RHEL Product and Program Management 2007-11-28 22:58:06 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 John Matthews 2008-02-25 10:23:40 EST
svn info
137244

Modified:
   branches/eng/client/rhel/rhel-4/up2date/up2date.py


Basically, deps were being addressed for "install/update" only, added ability to
resolve deps for removal.

Comment 6 errata-xmlrpc 2008-07-24 16:05:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0771.html

Note You need to log in before you can comment on or make changes to this bug.