Bug 300331 - USB Keyboard does not work during boot selection on Dell Precision 690
USB Keyboard does not work during boot selection on Dell Precision 690
Status: CLOSED DUPLICATE of bug 240866
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-09-21 09:58 EDT by Michael Wiktowy
Modified: 2008-06-04 10:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-04 10:44:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Wiktowy 2007-09-21 09:58:39 EDT
Description of problem:

On my Dell Precision 690, when booting from the F8test2 LiveCD, the USB keyboard
is dead during the boot selection screen so that I cannot select any other boot
option. I just have to wait for the timeout to select the default option. Before
the menu (pressing f12 to trigger the boot to CD)  and once the system boots up
(at the password prompt), the USB keyboard works fine.

Version-Release number of selected component (if applicable):
f8test2 LiveCD

How reproducible:
Always. The only LiveCD that will allow me to select a boot option is the Ubuntu
7.04 64-bit version.

Steps to Reproduce:
1. Boot with LiveCD
2. Try to select something other than the default boot option
Actual results:
System not recognizing key presses.

Expected results:
Should be able to scroll up and down and pick boot option or memory test, etc.

Additional info:
Originally reported in Bug 227745 but I thought that I would separate it out as
it is different enough to be independent (different arch).
Comment 1 Michael Wiktowy 2007-09-21 10:54:28 EDT
It seems that Ubuntu 7.04 LiveCD in both 32bit and 64 bit variants, which are
based on Isolinux 3.11, allow the keyboard to work on this system.

UBCD v4.1.1 shares the same problem as Fedora LiveCDs. 
Comment 2 Michael Wiktowy 2007-09-27 22:40:56 EDT
This problem is still present with the rawhide-20070925 LiveCD that uses
Isolinux 3.36
Comment 3 Matt Domsch 2007-10-11 23:58:14 EDT
Please try Fedora 8 Test 3.  there was a syslinux bug fixed at the last minute
for that.
Comment 4 Michael Wiktowy 2007-10-12 20:13:18 EDT
I didn't see your comment before I went and upgraded the BIOS from A03 to A06.
Now the boot menu works as expected but unfortunately I cannot verify the
functionality of any last minute workabounds to make syslinux work with A03 now.
Since UBCD v4.1.1 seems to work now too, it seems to be primarily a BIOS bug. I
don't know if this is something worth mentioning in the Release Notes for F8?
Comment 5 Pedro Lamarão 2007-10-30 19:54:52 EDT
This bug also happens with a Dell Dimension 5150 with Fedora 8 Test 3 Live CD.
Also with rawhide-i686-20071019 Live CD.

In this machine I can't actually boot the Live CD so it may be a different problem.
Comment 6 Luis Felipe Marzagao 2008-01-06 19:22:04 EST
Same problema here: Dell OptPlex GX620, BIOS version: A11

It happens with F8 (final realease) both install DVD and LiveCD.

Comment 7 Bug Zapper 2008-05-13 23:15:54 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 8 petrosyan 2008-06-04 10:44:28 EDT

*** This bug has been marked as a duplicate of 240866 ***

Note You need to log in before you can comment on or make changes to this bug.