Bug 300431 - Cannot connect to a wireless network with WEP
Cannot connect to a wireless network with WEP
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: NetworkManager (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-21 10:33 EDT by Cameron Meadors
Modified: 2012-05-16 09:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-16 09:06:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cameron Meadors 2007-09-21 10:33:43 EDT
I am not able to connect to a wireless netowrk with WEP with NM.  I can connect
using command line tools (ifconfig iwconfig).  NM asks for the key, then it
spins and finally I get the key dialog again.

I think that this is a problem caused by having an old key in my keyring that is
not correct.  I started having the problem when I migrated a home dir from a
Fedora 7 box where wireless worked fine, to a RHEL 5.1 beta box.  About the same
time the wep key changed.

I have checked the key in the key ring and it is not the correct key.  I have
been asked to unlock the keyring, so NM must be looking at the key.
Comment 1 Dan Williams 2008-03-28 14:21:29 EDT
Does NM ever ask you for a new key?  If after entering the new key, does a
successful connection happen?  If a successful connection does happen, is the
new key stored in the keyring?  If the key is wrong and NM can't connect, it
_should_ ask you for a new key by bringing up the wireless key dialog.  If
that's not coming up (yet the applet claims it's waiting for a key) then it
might be bug #223119.
Comment 2 Cameron Meadors 2008-04-03 11:23:03 EDT
This issues was complicated by various suspend resume testing.  I was prompted
for a new key after it failed to connect.  I gave it the correct key and it
still failed.  I deleted the key from gconf and still couldn't connect.  I then
rebooted and tried again.  This time it asked me for the key and connected.

I will have to set up a test env to reproduce since I now have the new key working.
Comment 3 Dan Williams 2009-11-12 16:06:34 EST
Any idea if you're still seeing this with latest RHEL?  Pretty sure 5.1 still had NM 0.6.x, while we udpated to NM 0.7 in 5.2.  Which would require a retest.
Comment 5 RHEL Product and Program Management 2010-08-09 15:17:29 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.