Bug 300781 - No such file or directory: '/etc/sysconfig/hwconfig'
No such file or directory: '/etc/sysconfig/hwconfig'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Greg Nichols
:
: 313521 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-21 12:51 EDT by Doug Chapman
Modified: 2007-10-16 07:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: hts-5.1-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-16 07:47:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2007-09-21 12:51:24 EDT
Description of problem:
The latest hts version does not run.  It appears to be looking for
/etc/sysconfig/hwconfig when it should be looking for /etc/sysconfig/hwconf.

[root@hpdiablo1 ~]# hts certify --test core
process 4226: Applications must not close shared connections - see
dbus_connection_close() docs. This is a bug in the application.
normal
Hardware: Red Hat unknown ParaVirt Guest
OS: Tikanga 5.1
saved configuration to /var/hts/config.xml
OS Version RHEL5, kernel rpm kernel-xen-2.6.18-47.el5
Traceback (most recent call last):
  File "/usr/bin/hts", line 126, in ?
    success = hts.do(args)
  File "/usr/share/hts/lib/hts/hardwaretest.py", line 68, in do
    return self.doCertify()
  File "/usr/share/hts/lib/hts/hardwaretest.py", line 194, in doCertify
    self.doPlan()
  File "/usr/share/hts/lib/hts/hardwaretest.py", line 148, in doPlan
    tests = planner.plan()
  File "/usr/share/hts/lib/hts/planner.py", line 99, in plan
    return self.__plan(self.devices)
  File "/usr/share/hts/lib/hts/planner.py", line 85, in __plan
    someTests = test.plan(self.devices)
  File "/usr/share/hts/tests/storage/greg-storage.py", line 51, in plan
    disk = self.getLogicalDevice(device.getProperty("info.linux.driver"))
  File "/usr/share/hts/tests/storage/greg-storage.py", line 70, in getLogicalDevice
    hwconfFile = open("/etc/sysconfig/hwconfig", "r")
IOError: [Errno 2] No such file or directory: '/etc/sysconfig/hwconfig'
[root@hpdiablo1 ~]#
[root@hpdiablo1 ~]# ls /etc/sysc
sysconfig/   sysctl.conf
[root@hpdiablo1 ~]# ls /etc/sysconfig/hwconf
[root@hpdiablo1 ~]# hts certify
loaded configuration /var/hts/config.xml
loaded configuration /var/hts/config.xml
OS Version RHEL5, kernel rpm kernel-xen-2.6.18-47.el5
Traceback (most recent call last):
  File "/usr/bin/hts", line 126, in ?
    success = hts.do(args)
  File "/usr/share/hts/lib/hts/hardwaretest.py", line 68, in do
    return self.doCertify()
  File "/usr/share/hts/lib/hts/hardwaretest.py", line 194, in doCertify
    self.doPlan()
  File "/usr/share/hts/lib/hts/hardwaretest.py", line 148, in doPlan
    tests = planner.plan()
  File "/usr/share/hts/lib/hts/planner.py", line 99, in plan
    return self.__plan(self.devices)
  File "/usr/share/hts/lib/hts/planner.py", line 85, in __plan
    someTests = test.plan(self.devices)
  File "/usr/share/hts/tests/storage/greg-storage.py", line 51, in plan
    disk = self.getLogicalDevice(device.getProperty("info.linux.driver"))
  File "/usr/share/hts/tests/storage/greg-storage.py", line 70, in getLogicalDevice
    hwconfFile = open("/etc/sysconfig/hwconfig", "r")
IOError: [Errno 2] No such file or directory: '/etc/sysconfig/hwconfig'


Version-Release number of selected component (if applicable):
hts-5.1-1.el5

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Greg Nichols 2007-09-21 13:41:30 EDT
/usr/share/hts/tests/storage/greg-storage.py is a stray file that shouldn't be
installed in hts.   As a work-around, delete this file, and run "hts clean", to
remove the old test plan and results.

This bug will be fixed in R3.
Comment 2 Greg Nichols 2007-10-01 10:13:56 EDT
*** Bug 313521 has been marked as a duplicate of this bug. ***
Comment 3 Satyabrata Maitra 2007-10-16 07:47:53 EDT
Retested the bug with hts-5.1-4. Its Fixed now and no traceback error showing.

Version of the component tested :-
hts-5.1-4

Tree followed :-
RHEL5.1-server-20071011.0

Note You need to log in before you can comment on or make changes to this bug.