Bug 30106 - Savage chipset testing status report
Summary: Savage chipset testing status report
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-28 22:52 UTC by David Lawrence
Modified: 2007-04-18 16:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-02 17:39:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Lawrence 2001-02-28 22:52:17 UTC
Savage 2000 32MB AGP
-------------------------------
o Installer did not detect this card properly. It was detected as a Generic
VGA Compatible.
o Chose Savage 2000 (generic) which was in the list of S3 cards and carried
on.
o 32MB memory properly detected.
o Installer X test functioned properly.
o post install works well.Installer set up to use the XFree86 4.0.2 driver
by default.
o No problems found at 1024 x 768 x 16.

lspci output
	02:00.0 S3 Inc. 86c410 Savage 2000 (rev 02)
lspci -n output
	02:00.0 Class 0300 5333:9102 (rev 02)

Savage 4 32MB AGP
--------------------------------
o Installer did not detect this card properly. It was detected as a Savage
(generic).
o Chose Savage 4 (generic) which was in the list of S3 cards and carried
on.
o 32MB memory properly detected.
o Installer X test functioned properly.
o Post install works well. Installer set up to use the XFree86 4.0.2 driver
by default.
o No problems found at 1024 x 768 x16.

lspci output
	02:00.0 VGA Compatible controller S3 Savage 4 (rev 04)
lspci -n output
	02:00.0 Class 0300  5333:8a22 (rev 04)

I will be doing the SavageIX/MX testing as soon as I can get my laptop
harddrive copied
off so I can restore back to my working system after install testing is
done. Should be done withthat one by end of Mar 1.

Comment 1 Bill Nottingham 2001-02-28 23:15:28 UTC
Savage2000 mapping added to kudzu, will be in 0.97.4-1.

The second is currently mapped as 'S3 Savage4', which seems correct.

Comment 2 David Lawrence 2001-03-01 16:46:14 UTC
Reopening bug until I verifiy that in the latest build, the Savage 4 card is
actually detected as a *Savage 4* and not as a Savage (Generic) regardless of
what the card database currently says. Also I am still testing the Savage IX/MX
chip in my laptop and will add the results here.

Comment 3 Matt Wilson 2001-03-01 16:54:37 UTC
you said you need to verify it -- it should be fixed in kudzu/Xconfigurator.


Comment 4 David Lawrence 2001-03-01 18:52:03 UTC
Savage IX/MX 8MB AGP
------------------------------------------
o Savage IX/MX mis-detected by installer as Savage (generic).

lspci
	01:00.0 VGA compatible controller: S3 Inc. 86C270-294 Savage/MX-/IX (rev 11)
lspci -n 
	01:00.0 Class 0300: 5333:8c12 (rev 11)


o Chose Savage MX which was in the list of S3 cards and carried on.
o 8MB memory properly detected.
o Installer X test functioned properly.
o Post install works well. Installer set up to use the XFree86 4.0.2 driver by
default.
o No problems found at 1024 x 768 x16.




Comment 5 Michael Fulbright 2001-03-01 18:57:35 UTC
So we can close this bug?

Comment 6 David Lawrence 2001-03-01 21:37:37 UTC
So are you saying it is not a bug that the specific chipsets are not being
suggested in Xconfigurator? I was under the impression that this was fixable.

Also, one more note. The installer sets the Savage cards up with XFree86 4.0.2
support but when running Xconfigurator post-install, it trys to install the
XF86_SVGA server by default. Is this proper 
behaviour? Looking through the Cards file I see that the Savage cards are setup
to use the SVGA server instead of the XFree86 4 server.


Comment 7 Glen Foster 2001-03-02 17:32:12 UTC
This defect considered MUST-FIX for Florence RC-2 (milestone *is* correct!)

Comment 8 Matt Wilson 2001-03-02 17:39:47 UTC
you *have* to be kidding.  This is *COMPLETELY COSMETIC*.  Holding a RC for this
is insane.

The only real bug I see here is that Xconfigurator set up XF86_SVGA while the
installer did the right thing (XFree4)


Comment 9 Preston Brown 2001-03-02 17:57:23 UTC
Savage MX cards will use XFree86 4.0.2 in Xconfigurator-4.9.16 and later.


Note You need to log in before you can comment on or make changes to this bug.