Bug 30127 - need additional version dependency on mktemp
Summary: need additional version dependency on mktemp
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-01 02:58 UTC by James Manning
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 03:06:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Manning 2001-03-01 02:58:55 UTC
since mkinitrd utilizes mktemp, it needs a version check against it.

Specifically, on a 6.2 box, I upgraded kernel, mkinitrd, and modutils,
but mkinitrd failed since the 6.2 mktemp wouldn't work for this setup:

jmm@bp6:/home/jmm> sudo mkinitrd /boot/initrd-2.4.1-0.1.9 2.4.1-0.1.9
error: -d option is not supported on Linux
error: -d option is not supported on Linux
Error creating temporaries.  Try again

Unable to confirm that a newer mktemp is indeed the "real" fix, as a 6.2
box can't upgrade glibc to 2.2.2 without big breakage and I haven't
rebuilt the source rpm yet.

Comment 1 James Manning 2001-03-01 03:03:58 UTC
confirmed... rebuilt mktemp-1.5-8 from .src.rpm and it works without the errors.

Comment 2 James Manning 2001-03-01 03:05:57 UTC
switchover to RHL Beta, as per glen's instructions (can't change this and
version at the same time, bear with me)

Comment 3 Matt Wilson 2001-03-01 03:07:35 UTC
fixed in mkinitrd-3.0.9



Note You need to log in before you can comment on or make changes to this bug.