Bug 30149 - up2date --nosig openmotif-devel fails with traceback
Summary: up2date --nosig openmotif-devel fails with traceback
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-01 05:12 UTC by Seth Vidal
Modified: 2015-01-07 23:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-02 17:33:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Seth Vidal 2001-03-01 05:12:29 UTC
running up2date --nosig openmotif-devel (to install that package) fails
with this traceback

Testing package set / solving RPM inter-dependencies...
Traceback (innermost last):
  File "/usr/sbin/up2date", line 638, in ?
    main()
  File "/usr/sbin/up2date", line 614, in main
    sys.exit(batchRun(onlyList, pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 327, in batchRun
    (depPackages,conflicts) = up2date.dryRun(selPkgList, printit, percent)
  File "/usr/share/rhn/up2date/up2date.py", line 1736, in dryRun
    for dep in deps:
TypeError: loop over non-sequence

not quite sure what to make of it - thought it might be useful to the
developers - and jeremy told me I had to file the bug or he'd hurt me.

:)
-sv

Comment 1 Adrian Likins 2001-03-01 16:12:52 UTC
what version of up2date client?



Comment 2 Adrian Likins 2001-03-01 16:17:24 UTC
this seems to be fixed in current cvs, it was missing a check it
needed.

Comment 3 Seth Vidal 2001-03-01 18:03:40 UTC
version 2.3.2-1 of the up2date client.



Comment 4 Glen Foster 2001-03-02 17:33:05 UTC
We need to fix this before the very next build

Comment 5 Preston Brown 2001-03-02 18:15:36 UTC
2.4 and later is fixed.


Note You need to log in before you can comment on or make changes to this bug.