Bug 301561 - Automatic detection of the sound card did not work anymore
Summary: Automatic detection of the sound card did not work anymore
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-lib   
(Show other bugs)
Version: 7
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-22 08:33 UTC by Stéphane Rochoy
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-27 13:31:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig.log when sound doesn't work (35.14 KB, text/plain)
2007-09-22 08:33 UTC, Stéphane Rochoy
no flags Details
scsrun.log when sound doesn't work (137 bytes, text/plain)
2007-09-22 08:34 UTC, Stéphane Rochoy
no flags Details
scsconfig.log when sound is ok (41.30 KB, text/plain)
2007-09-23 08:37 UTC, Stéphane Rochoy
no flags Details
scsrun.log when sound is ok (196 bytes, text/plain)
2007-09-23 08:37 UTC, Stéphane Rochoy
no flags Details

Description Stéphane Rochoy 2007-09-22 08:33:30 UTC
Description of problem:

I started a fresh install of the Fedora 7. During the install process, my sound
card, a Silicon AC'97, was properly detected and set up, i.e., I heard the
melody after using the "play" button.

Once the Fedora completly installed, I installed some packages, including XMMS
and audio-convert-mod. I then converted a few MP3 to Ogg and used XMMS to play
them: everything was just fine.

For now, XMMS refuse to play the same Ogg files with a "Couldn't open audio"
error message.

Going to the "Audio configuration" panel and using the "sound test" section of
the first selected card (Integrated Systems [SiS] AC'97 Sound Controller) don't
let me hear anything. So after clicking No, I get the message :

Automatic detection of the sound card did not work.  This audio device will not
be available on the system.

And here I am :)
  
Actual results:

Using XMMS to play a Ogg file: Couldn't open audio
Using the "Sound test": Automatic detection of the sound card did not work. 
This audio device will not be available on the system.

Expected results:
In both cases, something should be heard.

Additional info:
The problem persist accross reboots and is systematic.

Comment 1 Stéphane Rochoy 2007-09-22 08:33:30 UTC
Created attachment 202931 [details]
scsconfig.log when sound doesn't work

Comment 2 Stéphane Rochoy 2007-09-22 08:34:11 UTC
Created attachment 202941 [details]
scsrun.log when sound doesn't work

Comment 3 Stéphane Rochoy 2007-09-23 08:36:20 UTC
This morning, sound is ok. So I was wrong when I said the problem is systematic.

Comment 4 Stéphane Rochoy 2007-09-23 08:37:02 UTC
Created attachment 203361 [details]
scsconfig.log when sound is ok

Comment 5 Stéphane Rochoy 2007-09-23 08:37:23 UTC
Created attachment 203371 [details]
scsrun.log when sound is ok

Comment 6 Martin Stransky 2007-09-25 09:05:29 UTC
It's caused by your USB sound device when is plugged during boot. You can try to
rewrite your configuration files (in system-config-soundcard).

Comment 7 Stéphane Rochoy 2007-09-26 15:59:52 UTC
A motherboard problem? Anyway, it seems to solve.

Comment 8 Martin Stransky 2007-09-27 13:31:33 UTC
No, driver for your sound-card was not loaded because the it was blocked by USB
driver. There's a for for that in the latest system-config-soundcard in F8.
Closing as rawhide...


Note You need to log in before you can comment on or make changes to this bug.