Bug 30167 - PCMCIA hang completely a Dell Latitude C800
PCMCIA hang completely a Dell Latitude C800
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-01 08:42 EST by Alfredo Ferrari
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-13 12:56:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alfredo Ferrari 2001-03-01 08:42:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-3smp i686)


I tried wolverine on a Dell Latitude C800. Unfortunately the problems
with pcmcia are still there as with fisher. The machine hangs solid as soon
as pcmcia services start, solid means that I have to unplug the power
supply and remove the battery... even the power switch does not work.

The behaviour is exactly the same I found in Fisher. I did not report it at
that time since pcmcia were supposed to be buggy. On wolverine I
understood they should mostly work.

I know these Laptops as well many others from Dell are somewhat tricky,
also under RH7 and kernel 2.2.17 I had to compile the pcmcia package with
the pnp option on to get the cards working (as suggested on many sites as a
solution). If I take the wolverine kernel and recompile it without pcmcia
support, then the "external" pcmcia modules (compiled from
pcmcia-cs-21-feb-2001) work almost perfectly (scsi cardbus ok, modem ok,
still problems with the 3Com ethernet cardbus).

the followings are the last lines printed on logs before hanging

Feb 27 18:45:37 pceet215 kernel: PCI: Found IRQ 11 for device 02:0f.0
Feb 27 18:45:37 pceet215 kernel: PCI: The same IRQ used for device 00:1f.2
Feb 27 18:45:37 pceet215 kernel: PCI: The same IRQ used for device 02:0f.1
Feb 27 18:45:37 pceet215 kernel: PCI: The same IRQ used for device 02:0f.2
Feb 27 18:45:37 pceet215 kernel: PCI: Found IRQ 11 for device 02:0f.1
Feb 27 18:45:37 pceet215 kernel: PCI: The same IRQ used for device 00:1f.2
Feb 27 18:45:37 pceet215 kernel: PCI: The same IRQ used for device 02:0f.0
Feb 27 18:45:37 pceet215 kernel: PCI: The same IRQ used for device 02:0f.2
Feb 27 18:45:37 pceet215 kernel: Yenta IRQ list 0698, PCI irq11
Feb 27 18:45:37 pceet215 kernel: Socket status: 30000010
Feb 27 18:45:37 pceet215 kernel: Yenta IRQ list 0698, PCI irq11
Feb 27 18:45:37 pceet215 kernel: Socket status: 30000020
Feb 27 18:45:38 pceet215 kernel: cs: cb_alloc(bus 7): vendor 0x9004, device
0x6075
Feb 27 18:45:38 pceet215 kernel:   got res[e800:e8ff] for resource 0 of PCI
device 9004:6075

and the following is the output of lspci

00:00.0 Host bridge: Intel Corporation 82815 815 Chipset Host Bridge and
Memory Controller Hub (rev 02)
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort+ >SERR- <PERR-
	Latency: 0
	Region 0: Memory at e4000000 (32-bit, prefetchable)
	Capabilities: [88] #09 [f104]
	Capabilities: [a0] AGP version 2.0
		Status: RQ=31 SBA+ 64bit- FW- Rate=x1,x2
		Command: RQ=0 SBA+ AGP+ 64bit- FW- Rate=x2
00: 86 80 30 11 06 01 90 20 02 00 00 06 00 00 00 00
10: 08 00 00 e4 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
30: 00 00 00 00 88 00 00 00 00 00 00 00 00 00 00 00

00:01.0 PCI bridge: Intel Corporation: Unknown device 1131 (rev 02)
(prog-if 00 [Normal decode])
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
	Status: Cap- 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
	Latency: 32
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
	I/O behind bridge: 0000c000-0000cfff
	Memory behind bridge: fc000000-fdffffff
	Prefetchable memory behind bridge: e8000000-ebffffff
	BridgeCtl: Parity- SERR- NoISA+ VGA+ MAbort- >Reset- FastB2B-
00: 86 80 31 11 07 01 20 00 02 00 04 06 00 20 01 00
10: 00 00 00 00 00 00 00 00 00 01 01 20 c0 c0 a0 a2
20: 00 fc f0 fd 00 e8 f0 eb 00 00 00 00 00 00 00 00
30: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0c 00

00:1e.0 PCI bridge: Intel Corporation: Unknown device 2448 (rev 02)
(prog-if 00 [Normal decode])
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
	Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
	Latency: 0
	Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
	I/O behind bridge: 0000e000-0000ffff
	Memory behind bridge: f4000000-fbffffff
	BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
00: 86 80 48 24 07 01 80 00 02 00 04 06 00 00 01 00
10: 00 00 00 00 00 00 00 00 00 02 02 20 e0 f0 80 22
20: 00 f4 f0 fb f0 ff 00 00 00 00 00 00 00 00 00 00
30: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 06 00

00:1f.0 ISA bridge: Intel Corporation: Unknown device 244c (rev 02)
	Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
	Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
	Latency: 0
00: 86 80 4c 24 0f 01 80 02 02 00 01 06 00 00 80 00
10: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
30: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

00:1f.1 IDE interface: Intel Corporation: Unknown device 244a (rev 02)
(prog-if 80 [Master])
	Subsystem: Intel Corporation: Unknown device 4541
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
	Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
	Latency: 0
	Region 4: I/O ports at bfa0
00: 86 80 4a 24 05 00 80 02 02 80 01 01 00 00 00 00
10: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
20: a1 bf 00 00 00 00 00 00 00 00 00 00 86 80 41 45
30: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

00:1f.2 USB Controller: Intel Corporation: Unknown device 2442 (rev 02)
(prog-if 00 [UHCI])
	Subsystem: Intel Corporation: Unknown device 4541
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
	Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
	Latency: 0
	Interrupt: pin D routed to IRQ 11
	Region 4: I/O ports at dce0
00: 86 80 42 24 05 00 80 02 02 00 03 0c 00 00 00 00
10: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
20: e1 dc 00 00 00 00 00 00 00 00 00 00 86 80 41 45
30: 00 00 00 00 00 00 00 00 00 00 00 00 0b 04 00 00

01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility M4
AGP (prog-if 00 [VGA])
	Subsystem: Dell Computer Corporation: Unknown device 00a3
	Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop+ ParErr-
Stepping+ SERR- FastB2B-
	Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
	Interrupt: pin A routed to IRQ 11
	Region 0: Memory at e8000000 (32-bit, prefetchable)
	Region 1: I/O ports at cc00
	Region 2: Memory at fcffc000 (32-bit, non-prefetchable)
	Capabilities: [50] AGP version 2.0
		Status: RQ=31 SBA+ 64bit- FW- Rate=x1,x2
		Command: RQ=31 SBA+ AGP+ 64bit- FW- Rate=x2
	Capabilities: [5c] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
00: 02 10 46 4d a3 00 b0 02 00 00 00 03 08 20 00 00
10: 08 00 00 e8 01 cc 00 00 00 c0 ff fc 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 28 10 a3 00
30: 00 00 00 00 50 00 00 00 00 00 00 00 0b 01 08 00

02:03.0 Multimedia audio controller: ESS Technology ES1983S Maestro-3i PCI
Audio Accelerator (rev 10)
	Subsystem: Dell Computer Corporation: Unknown device 00a3
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
	Latency: 32 (500ns min, 6000ns max)
	Interrupt: pin A routed to IRQ 5
	Region 0: I/O ports at ec00
	Region 1: Memory at f8ffe000 (32-bit, non-prefetchable)
	Capabilities: [c0] Power Management version 2
		Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA
PME(D0-,D1+,D2+,D3hot+,D3cold-)
		Status: D0 PME-Enable+ DSel=0 DScale=0 PME-
00: 5d 12 98 19 07 00 90 02 10 00 01 04 00 20 00 00
10: 01 ec 00 00 00 e0 ff f8 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 28 10 a3 00
30: 00 00 00 00 c0 00 00 00 00 00 00 00 05 01 02 18

02:0f.0 CardBus bridge: Texas Instruments PCI4451 PC card Cardbus
Controller
	Subsystem: Dell Computer Corporation: Unknown device 00a3
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
	Latency: 32, cache line size 08
	Interrupt: pin A routed to IRQ 11
	Region 0: Memory at f4000000 (32-bit, non-prefetchable)
	Bus: primary=02, secondary=03, subordinate=06, sec-latency=32
	I/O window 0: 00000000-00000003
	I/O window 1: 00000000-00000003
	BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset+ 16bInt+ PostWrite+
	16-bit legacy interface ports at 0001
00: 4c 10 42 ac 07 00 10 02 00 00 07 06 08 20 82 00
10: 00 00 00 f4 a0 00 00 02 02 03 06 20 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
30: 00 00 00 00 00 00 00 00 00 00 00 00 0b 01 c0 07
40: 28 10 a3 00 01 00 00 00 00 00 00 00 00 00 00 00
50: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
60: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

02:0f.1 CardBus bridge: Texas Instruments PCI4451 PC card Cardbus
Controller
	Subsystem: Dell Computer Corporation: Unknown device 00a3
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
	Latency: 32, cache line size 08
	Interrupt: pin A routed to IRQ 11
	Region 0: Memory at f4001000 (32-bit, non-prefetchable)
	Bus: primary=02, secondary=07, subordinate=0a, sec-latency=32
	Memory window 0: 60000000-60021000 (prefetchable)
	I/O window 0: 00000100-0000017f
	I/O window 1: 00000000-00000003
	BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset- 16bInt+ PostWrite+
	16-bit legacy interface ports at 0001
00: 4c 10 42 ac 07 00 10 02 00 00 07 06 08 20 82 00
10: 00 10 00 f4 a0 00 00 22 02 07 0a 20 00 00 00 60
20: 00 10 02 60 00 00 00 00 00 00 00 00 00 01 00 00
30: 7c 01 00 00 00 00 00 00 00 00 00 00 0b 01 80 07
40: 28 10 a3 00 01 00 00 00 00 00 00 00 00 00 00 00
50: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
60: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

02:0f.2 FireWire (IEEE 1394): Texas Instruments: Unknown device 8027
(prog-if 10 [OHCI])
	Subsystem: Dell Computer Corporation: Unknown device 00a3
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
	Latency: 32 (500ns min, 1000ns max), cache line size 08
	Interrupt: pin A routed to IRQ 11
	Region 0: Memory at f8ffd800 (32-bit, non-prefetchable)
	Region 1: Memory at f8ff8000 (32-bit, non-prefetchable)
	Capabilities: [44] Power Management version 2
		Flags: PMEClk- DSI- D1- D2+ AuxCurrent=0mA
PME(D0-,D1-,D2+,D3hot+,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
00: 4c 10 27 80 16 01 10 02 00 10 00 0c 08 20 80 00
10: 00 d8 ff f8 00 80 ff f8 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 28 10 a3 00
30: 00 00 00 00 44 00 00 00 00 00 00 00 0b 01 02 04


Reproducible: Always
Steps to Reproduce:
1.Install the kernel and pcmcia packages from wolverine on a Dell Latitude
C800
2.Boot from the new kernel
3.issue service pcmcia start
	

Actual Results:  the machine hangs completely

Expected Results:  pcmcia services should start
Comment 1 Arjan van de Ven 2001-03-01 15:27:53 EST
Can you try to detect if you are loading "yenta_socket.o" or  "i82365.o" ?
2.4 kernels should use yenta_socket.o for cardbus controllers...
Comment 2 Alfredo Ferrari 2001-03-01 17:16:32 EST
Hi, yes of course I was using yenta_socket.o as reported in the log above (even
though it is never written in a clear way, I knew from the various mailing list
that this is the way pcmcia should work on 2.4). The /etc/sysconfig/pcmcia file
was:

PCMCIA=yes
PCIC=yenta_socket
PCIC_OPTS=""
CORE_OPTS=
CARDMGR_OPTS="-v -f"

Please again note that there are clear indications that the most recent Dell
Laptos are "misunderstood" by all pcmcia flavours, kernel (Linus) or external
(D.HInds) ones, both with 2.2 or 2.4 kernels. The "external" drivers work if you
tweak them setting on the "pnp" option. There are several consistent messages on
the pcmcia forum at sourceforce.net and in the Dell laptop lists showing this
behaviour. I am ready to supply all extra infos you may need.

I am writing this message connected happily with kernel 2.2.17, pcmcia-cs-3.1.24
recompiled with "pnp" ... the only combination which fully works up to now.

Comment 3 Michael K. Johnson 2001-03-02 15:13:19 EST
We have tested this on two such laptops here without being able
to reproduce it, and Dell has also not been able to reproduce
the bug.
Comment 4 Matt Wilson 2001-03-02 17:05:22 EST
please attach your /etc/pcmcia/config.opts
Comment 5 Alfredo Ferrari 2001-03-03 10:08:29 EST
I am running bios a02, I had (and still have) kernel-2.2.17-4 together
with the wolverine kernel. System hangs occurred with an Adaptec AP1480A
and a 3Com 3C575  in the two sockets. Both are cardbus cards. I got a
similar hang with the APA1480A and a Psion Gold card instead of the 3Com.

However, latest news, interacting with other RH guys (Mike Harris and Bill
Nottingham) in order to get hardware 3D acceleration working, I installed
a further version of the kernel and pcmcia-cs from rawhide (with some
extra patches for the graphic card they sent me).

With this kernel I was just now able to get PCMCIA partially working if

a) the APA1480A is NOT there
b) a given memory range (0x800-0x8ff) which is apparently unused according to
/proc/ioports and which was required in the past to get the two
cardbus and/or Psion modem  and the OSS/4Technology drivers working
together is excluded from /etc/pcmcia/config.opts. This last remark is
my fault, I left it because it was needed under kernels 2.2.16 in order
to get all the above work, under 2.2.17 it doesn't hurt as well as under 2.4.1
with D.Hinds PCMCIA modules (same exact machine and system, the only difference
being the kernel I boot from), it seems to be dangerous with 2.4.1

So the present status is (kernel 2.4.1-0.1.14 plus r128 patches,
and kernel-pcmcia-cs-3.1.24-0.5)

- the Psion Gold Card is recognized (I suppose it works, not yet tested)
- The 3Com575 is recognized and works after I "ifup" manually the network
  (a bug reported in the realese notes of Wolverine)
- The APA1480A still does not work. If I boot with that card inserted and
  with port 0x800-0x8ff excluded, the system does no longer hang, but
  the card does not work giving:

Mar  2 21:19:32 pceet215 cardmgr[452]: initializing socket 1
Mar  2 21:19:32 pceet215 cardmgr[452]: initializing socket 1
Mar  2 21:19:32 pceet215 cardmgr[452]: socket 1: Adaptec APA-1480 SCSI
Host Adap
ter
Mar  2 21:19:32 pceet215 cardmgr[452]: socket 1: Adaptec APA-1480 SCSI
Host Adap
ter
Mar  2 21:19:33 pceet215 cardmgr[452]:   product info: "Adaptec",
"APA-1480 SCSI
 Host Adapter", "", ""
Mar  2 21:19:33 pceet215 cardmgr[452]:   product info: "Adaptec",
"APA-1480 SCSI
 Host Adapter", "", ""
Mar  2 21:19:33 pceet215 cardmgr[452]:   manfid: 0x012f, 0xcb01  function:
8 (SC
SI)
Mar  2 21:19:33 pceet215 cardmgr[452]:   manfid: 0x012f, 0xcb01  function:
8 (SC
SI)
Mar  2 21:19:33 pceet215 cardmgr[452]: executing: 'modprobe cb_enabler'
Mar  2 21:19:33 pceet215 cardmgr[452]: executing: 'modprobe cb_enabler'
Mar  2 21:19:33 pceet215 cardmgr[452]: executing: 'modprobe apa1480_cb'
Mar  2 21:19:33 pceet215 cardmgr[452]: executing: 'modprobe apa1480_cb'
Mar  2 21:19:33 pceet215 cardmgr[452]: + modprobe: Can't locate module
apa1480_c
b
Mar  2 21:19:33 pceet215 cardmgr[452]: + modprobe: Can't locate module
apa1480_c
Mar  2 21:19:33 pceet215 cardmgr[452]: modprobe exited with status 255
Mar  2 21:19:33 pceet215 cardmgr[452]:modprobe exited with status 255

The 3Com card works, even though there are some intial complains in the logs:

Mar  2 19:47:05 pceet215 kernel: Yenta IRQ list 0698, PCI irq11
Mar  2 19:47:05 pceet215 kernel: Socket status: 30000020
Mar  2 19:47:06 pceet215 kernel: cs: cb_alloc(bus 7): vendor 0x10b7, device 0x52
57
Mar  2 19:47:06 pceet215 kernel:   got res[e800:e87f] for resource 0 of PCI devi
ce 10b7:5257
Mar  2 19:47:06 pceet215 kernel:   got res[f5000000:f500007f] for resource 1 of 
PCI device 10b7:5257
Mar  2 19:47:06 pceet215 kernel:   got res[f5000080:f50000ff] for resource 2 of 
PCI device 10b7:5257
Mar  2 19:47:06 pceet215 kernel:   got res[f4c00000:f4c1ffff] for resource 6 of 
PCI device 10b7:5257
Mar  2 19:47:06 pceet215 kernel: PCI: Enabling device 07:00.0 (0000 -> 0003)
Mar  2 19:47:06 pceet215 kernel: PCI: No IRQ known for interrupt pin A of device
 07:00.0. Please try using pci=biosirq.

My present config.opts files is:

#
# Local PCMCIA Configuration File
#
#----------------------------------------------------------------------

# System resources available for PCMCIA devices

include port 0x100-0x4ff
# include port 0x800-0x8ff
include port 0xc00-0xcff
include memory 0xc0000-0xfffff
include memory 0xa0000000-0xa0ffffff, memory 0x60000000-0x60ffffff

# High port numbers do not always work...
# include port 0x1000-0x17ff

# Extra port range for IBM Token Ring
include port 0xa00-0xaff

# Resources we should not use, even if they appear to be available

# Resources we should not use, even if they appear to be available
# ??? Why ttyS1 is taking 2 ???
# exclude irq 2
# First built-in serial port
exclude irq 4
# Second built-in serial port
#exclude irq 3
# First built-in parallel port
exclude irq 7
# ??? Why something is taking 9 ???
# exclude irq 9
# PS/2 Mouse controller port, comment this out if you don't have a PS/2
# based mouse
exclude irq 12

#----------------------------------------------------------------------

# Examples of options for loadable modules

# To fix sluggish network with IBM ethernet adapter...
#module "pcnet_cs" opts "mem_speed=600"

# Options for IBM Token Ring adapters
#module "ibmtr_cs" opts "mmiobase=0xd0000 srambase=0xd4000"
# Options for Raylink/WebGear driver: uncomment only one line...
# Generic ad-hoc network
module "ray_cs" opts "essid=ADHOC_ESSID hop_dwell=128 beacon_period=256 translat
e=1"
# Infrastructure network for older cards
#module "ray_cs" opts "net_type=1 essid=ESSID1"
# Infrastructure network for WebGear
#module "ray_cs" opts "net_type=1 essid=ESSID1 translate=1 hop_dwell=128 beacon_
period=256"

# Options for WaveLAN/IEEE driver (AccessPoint mode)...
#module "wvlan_cs" opts "station_name=MY_PC"
# Options for WaveLAN/IEEE driver (ad-hoc mode)...
#module "wvlan_cs" opts "port_type=3 channel=1 station_name=MY_PC"

# Options for Xircom Netwave driver...
#module "netwave_cs" opts "domain=0x100 scramble_key=0x0"

# Try to get aha152x on the right interrupt
module "aha152x_cs" opts "irq_list=10"
# Try to get ttyS1 on the right interrupt
module "serial_cs" opts "irq_list=3,9"

The last lines are "historical" I was always crazy in avoiding interrupt
conflicts on my previous Latitudes.

This is the present status (muuuuch better than before). The APA1480A
does indeed work flawlessly with the latest beta release of the "old"
PCMCIA drivers from D. Hinds. All cards work correctly with
kernel-2.2.17-14 and pcmcia-cs-3.1.24 if and only if the latter is
compiled with the pnp option.

          Cheers
         Alfredo
Comment 6 Matt Domsch 2003-02-13 12:56:13 EST
This appears to be closed as resolved in a newer release.  Closing.

Note You need to log in before you can comment on or make changes to this bug.