Bug 30170 - Full-Table-Mapped APIC mode causes a problem with installing Kernel Linux version 2.4.1-0.1.9smp or later.
Full-Table-Mapped APIC mode causes a problem with installing Kernel Linux ver...
Status: CLOSED DUPLICATE of bug 28907
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Ingo Molnar
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-01 10:02 EST by Bryan Leopard
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 17:56:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Leopard 2001-03-01 10:02:31 EST
SUGGESTED PRIORITY: HIGH

SW CONFIGURATION:
SmartStart v4.90, v.4.91, v.5.00
Red Hat Linux v7.1E
Kernel Linux version 2.4.1-0.1.9smp

HW CONFIGURATION (Just a case)
Server====>DL360
CPU=======>1GHz * 2
Sys Rom===>P21 01/11/01
RAM=======>128MB
HDD=======>18.2 * 1

Primary===>Wide U2 SCSI
NIC=======>NC3163

STEP TO RECREATE THE PROBLEM:
1) Select manual path and Linux OS in SmartStart.
2) Go through System Configuration and other steps needed.
3) Complete SmartStart interview and launch OS installation.
4) Server fails to boot up after finishing entire installation.


PROBLEM DESCRIPTION: System Configuration Utility selects Full-table 
mapped APIC table when it recognizes multi-processor installed in its 
hardware. Then, its kernel 2.4.1-0.1.9smp fails installation and comes 
into a stuck while booting up. The boot console repeats timeout logs.

SCSI host 0 abort (pid 0) timed out - resetting
SCSI bus is being reset for 0 channel 0.
Sym53c8xx_reset: pid=0 reset_flags=2 serial_number=1 
serial_number_at_timeout=1


I'm happy finally report that we have found a fix for this issue. A patch 
from Alan Cox (one of the kernel popes) was just released (2.4.2. kernel - 
Alan Cox patch 5 is the version we tested in the lab). This patch appears 
to have fixed the problems that were encountered when installing the 
newest kernel on a ROC-enabled system (e.g. DL360 & DL380). Using a DL380 
with ROC installed, we patched the 2.4 kernel with Alan Cox's latest patch 
and it successfully loaded in Full Table Mapped mode. This, of course, 
concludes that there is a problem with the kernel and all of the 
distributions will need to be notified accordingly. We can't say "exactly" 
(meaning specific lines of code) what in Alan Cox's patch fixes this 
problem at this time, but I'm sure each distribution has their own ways of 
fixing the affected files. We do know that it has to do with the files 
pertaining to APIC.
Comment 1 Michael K. Johnson 2001-03-01 21:35:53 EST
We already resolved this bug working with you a few days ago.


*** This bug has been marked as a duplicate of 28907 ***
Comment 2 Richard Black 2001-03-14 12:52:57 EST
The following SCSI issues should prove to be dependent upon the APIC fix found 
in Linux Kernel 2.4.2-patch5.  These SCSI issues are being tested at this time, 
now that the latest beta seems to have the needed patch.

30170 - Full-Table-Mapped APIC mode causes a problem with installing Kernel 
Linux version 2.4.1-0.1.9smp or later.
26632 - Cannot install to a Compaq array controller - hang
26633 - SCSI Timeout Errors on NCR53c1510D / sym53c1510D
26634 - [aic7xxx] Kernel Bug, 64bit slot, adaptec ctrlr, DL360
Comment 3 Richard Black 2001-03-19 10:16:57 EST
qa0309 does not have the fix needed.  Drivers still error out (timeouts, 
hangs, ...)

Note You need to log in before you can comment on or make changes to this bug.