Bug 30174 - kudzu deletes /dev/mouse when PS2 mouse still attached
kudzu deletes /dev/mouse when PS2 mouse still attached
Status: CLOSED DUPLICATE of bug 18862
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-01 10:31 EST by Need Real Name
Modified: 2014-03-16 22:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 10:36:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-01 10:31:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)


I replaced my PS2 mouse with a USB mouse.  When kudzu ran, I told it to 
leave my PS2 mouse configuration alone (Do Nothing) and create a new 
configuration for the USB mouse.  This worked fine.  Then I swapped mice 
again, removing the USB mouse and replacing the PS2 mouse.  kudzu ran 
again, saying that the USB mouse was gone.  I told it (naturally) to 
remove the USB mouse configuration.  As part of the removal, kudzu 
deleted /dev/mouse, which was still needed by the PS2 mouse.  As a result, 
the computer became unable to start the X server on boot: gdm complained 
that /dev/mouse was missing.

Reproducible: Didn't try
Steps to Reproduce:
1. Swap your PS2 mouse for a USB mouse and start the computer.
2. When kudzu asks what to do with the PS2 mouse configuration, say Do 
Nothing.
3. When kudzu asks about the USB mouse, say Add Configuration (or whatever 
the words are).
4. Computer boots normally.  USB mouse works.
5. Shutdown computer.
6. Remove USB mouse and replace PS2 mouse.  Boot.
7. When kudzu asks what to do with the missing USB mouse, tell it to 
remove the configuration.
8. Computer continues booting, but when it's time to launch the X server, 
the monitor displays garbage as X tries over and over to start up 
unsuccessfully.  
	

Actual Results:  /var/log/messages on the failed boot:

Feb 28 22:40:16 spinky gpm[680]: oops() invoked from gpm.c(968)%
Comment 1 Need Real Name 2001-03-01 10:36:32 EST
My /var/log/messages output got truncated.  Here it is again.

Feb 28 22:40:16 spinky gpm[680]: oops() invoked from gpm.c(968)
Feb 28 22:40:16 spinky gpm[680]: /dev/mouse: Function not implemented
 [...]
Feb 28 22:42:47 spinky modprobe: modprobe: Can't locate module char-major-81
Feb 28 22:42:49 spinky gdm[1286]: gdm_slave_windows_kill_ioerror_handler: Fatal 
X error - Restarting :0

Comment 2 Bill Nottingham 2001-03-01 10:40:05 EST

*** This bug has been marked as a duplicate of 18862 ***

Note You need to log in before you can comment on or make changes to this bug.