Bug 301951 - iwl4965 firmware trouble
iwl4965 firmware trouble
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iwl4965-firmware (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Nicolas Chauvet (kwizart)
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-22 20:56 EDT by Ole Tøsse Kolvik
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-26 13:33:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ole Tøsse Kolvik 2007-09-22 20:56:20 EDT
Description of problem:

I had to download the firmware (same version as installed with fedora8) and
replace it with the one installed. Once I did that, the device worked.

Version-Release number of selected component (if applicable):

4.44.1.18

How reproducible:


Steps to Reproduce:
1. Install Fedora 8.
2. Check if wireless is available.
3. ??
  
Actual results:

No wireless device available

Expected results:

A wireless device to go online with.

Additional info:

None
Comment 1 Nicolas Chauvet (kwizart) 2007-09-23 05:44:24 EDT
Well, sorry  i didn't understood what's the problem here...

Actually iwl4965-firmware bundles two firmwares, 
4.44.1.18 and 4.44.17 - There is no new firmware image unless not public yet...
So, this is possible to use a previous kernel t

Are you sure the iwl4965-firmware package come from the Fedora version ?
do rpm -qi iwl4965-firmware should a buildserver at fedoraprojet ?

closing to not a bug for now but be sure to re-open if there is a problem
Comment 2 Nicolas Chauvet (kwizart) 2007-09-23 05:49:26 EDT
well sorry missunderstood that it's worked...
So you just wanted it to be installed by default... This might be done for next F8T3
Comment 3 Nicolas Chauvet (kwizart) 2007-09-26 13:33:25 EDT
Ok iwl4965-firmware is now added by default and will be provided with the next
F8t3 release
Comment 4 Ole Tøsse Kolvik 2007-09-28 13:50:07 EDT
I installed from DVD, so I guess that's why they were installed on my system.

But that wasn't what I meant. My problem was that i beleived that the firmware
was the reason that my wireless card didn't work on boot. So when i replaced the
firmware with the one i downloaded and reprobed the module, it worked.

But, I re-installed Fedora the other day and it seems that the only thing I need
to do is to reprobe the module. 

So that's the real problem it seems. That the card is detected, but not enabled
before i reprobe the module.
Comment 5 Nicolas Chauvet (kwizart) 2007-10-01 20:53:54 EDT
I don't knwo then... probably a problem with the module?...
Do you meant you need to do this for each reboot ?
Comment 6 Ole Tøsse Kolvik 2007-10-04 16:42:54 EDT
Yeah, I had to do it for every reboot. But hey, looks like that's been fixed for
Test3. So everything works perfectly with my wirelesscard now :)

Note You need to log in before you can comment on or make changes to this bug.