Bug 302011 - Yum no longer giving popups
Yum no longer giving popups
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-23 00:18 EDT by Peter H. Jones
Modified: 2014-01-21 17:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-23 18:06:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter H. Jones 2007-09-23 00:18:41 EDT
Description of problem:
Yum popup showed about 35 new updates on Sep 22. Of these, I chose only the
kernel. Since rebooting, I have not seen the popup. although the
System/Administration/Service shows yum-updatesd to be running.

Version-Release number of selected component (if applicable):
yum-updatesd-0.5-2.fc8
yum-metadata-parser-1.1.2-1.fc8
yum-3.2.5-3.fc8
yum-refresh-updatesd-1.1.7-1.fc8

How reproducible:
I now have this bug always, even if I choose to start the former kernel. It
would be difficult for me to get my system back to the way it was before the yum
problem occurred, and I don't know of a way to set the update server back the
way it was. 

Steps to Reproduce:
1. Chose only kernel update, rebooted, then closed popup by clicking on its X.
Popup does not return, even after reboot. Don't know if it's possible to
reproduce easily.
  
Actual results:
No more yum popups.

Expected results:
Yum popup should still occur, as I have yet to download all the updates 

Additional info:

I don't see yum-refresh-updatesd listed as a service, running or not. But
I presume "yum check-update" (see below) should work, daemons or not.

Tried yum check-update with debugging:
]# yum -d 20 check-update
Loading "refresh-updatesd" plugin
Yum Version: 3.2.5
COMMAND: yum -d 20 check-update 
Installroot: /
Reading Local RPMDB
Setting up Package Sacks
Running "postreposetup" handler for "refresh-updatesd" plugin
Building updates object
skipping reposetup, pkgsack exists
skipping reposetup, pkgsack exists
putting openssl in complex update
putting glibc in complex update
putting kernel in complex update
processing openssl
processing glibc.i686
processing kernel.i686
Running "close" handler for "refresh-updatesd" plugin

Haven't tried yum clean yet, willing to try if advised to.

I can download updates from
ftp://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/Packages ,
and install with rpm. But yum check-updates is not seeing there are new updates.

Last installed packages are:
tail /var/log/yum.log
Sep 20 23:12:47 Updated: texinfo - 4.11-1.fc8.i386
Sep 20 23:12:49 Updated: system-config-printer-libs - 0.7.74.2-1.fc8.i386
Sep 20 23:12:50 Updated: system-config-printer - 0.7.74.2-1.fc8.i386
Sep 20 23:12:50 Updated: texinfo-tex - 4.11-1.fc8.i386
Sep 20 23:12:51 Updated: xorg-x11-drv-ati - 6.7.193-1.fc8.i386
Sep 20 23:12:52 Updated: udev - 115-3.20070920git.fc8.i386
Sep 20 23:12:53 Updated: pm-utils - 0.99.4-3.fc8.i386
Sep 20 23:12:53 Updated: xorg-x11-drv-nv - 2.1.3-2.fc8.i386
Sep 20 23:12:54 Updated: telnet - 1:0.17-40.fc8.i386
Sep 22 09:57:04 Installed: kernel - 2.6.23-0.193.rc7.git1.fc8.i686
Comment 1 Peter H. Jones 2007-09-23 18:06:21 EDT
Now working again Sep 23, 2007.

Note You need to log in before you can comment on or make changes to this bug.