Bug 30206 - tar arguments have changed since 7.0
Summary: tar arguments have changed since 7.0
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tar (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-01 20:40 UTC by Ed Marshall
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 20:40:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed Marshall 2001-03-01 20:40:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.14 i686)


The arguments to "tar" for decompressing bzip2'd files on-the-fly have
changed since the 7.0 release; instead of using "-I" for decompressing
bzip2'd data, the argument is now "-j". "-I" is completely ignored.

Reproducible: Always
Steps to Reproduce:
cp /etc/passwd blah.txt
tar cvvf blah.tar blah.txt
bzip2 -9 blah.tar
tar Ixvvf blah.tar.bz2 (on 7.0)
tar jxvvf blah.tar.bz2 (on fisher or wolverine)

Not that this is a real painful change, but it appears to have been
gratuitously made incompatible without any documentation of the fact. Looks
like a note for the release notes, more than anything.

Comment 1 Bernhard Rosenkraenzer 2001-03-01 20:47:34 UTC
While this is not a bug, we agree and reverted tar to the old behavior in
1.13.19-2.


Note You need to log in before you can comment on or make changes to this bug.