Bug 302331 - sound stopped working
sound stopped working
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: warzone2100 (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Karol Trzcionka
Fedora Extras Quality Assurance
:
: 262561 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-23 15:41 EDT by Andrew Ziem
Modified: 2007-12-07 00:09 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.0.8-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 17:50:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Ziem 2007-09-23 15:41:35 EDT
Description of problem:
A month or two ago, Warzone's sound worked fine.  Now, it doesn't.  However,
other applications (e.g. Rhythmbox) work fine.  As far as I remember, the only
changes I made were applying updates through yum.  I tried rebooting.

Version-Release number of selected component (if applicable):
warzone2100-data-2.0.7-3.fc7
warzone2100-2.0.7-3.fc7


How reproducible:
Always

Steps to Reproduce:
1. Run warzone2100
2. Listen
  
Actual results:
Difficulty playing because there's no audio

Expected results:
Audio

Additional info:
Comment 1 Karol Trzcionka 2007-09-23 15:52:35 EDT
*** Bug 262561 has been marked as a duplicate of this bug. ***
Comment 2 Karol Trzcionka 2007-09-23 15:58:16 EDT
At now I have only one solution: downgrade libvorbis
Sound in the new version of warzone2100 (on svn) works fine, but the game is not
stable. I'll try to fix v2.0.7 basing on svn, but it is not easy.
Comment 3 Patrick Ohearn 2007-12-05 01:40:32 EST
there is a Linux only audio fix release out, 2.0.9. Can we get this pushed to
updates-testing as this fixes the audio problem. It also fixes the training map
loking up (due to audio issues?).
Comment 4 Karol Trzcionka 2007-12-05 13:09:00 EST
The repo version 2.0.8 (next update) is fixed, so I don't see any idea to
release 2.0.9 (sources after patching are the same).
Comment 5 The Source 2007-12-05 13:31:37 EST
Where's version for Fedora 8? Found nothing in repo today
Comment 6 Patrick Ohearn 2007-12-05 19:13:26 EST
While playing with version warzone2100-2.0.8-0.1.rc1.fc8 I get the following error.

[patoh@asmodeus][~]
% warzone2100 
open /dev/[sound/]dsp: Permission denied
error:      OpenAL Vendor: (null)
OpenAL Version: (null)
OpenAL Renderer: (null)
OpenAL Extensions: (null)
error:      Couldn't open audio device.
error:      loadFile2: optional file sequenceaudio/brfcom.txt could not be found!
error:      loadFile2: optional file sequenceaudio/cam1/cam1ascv.txt could not
be found!
Comment 7 The Source 2007-12-06 01:46:30 EST
Heeeey! Where's x86_64 version??? If there's no such version, at least place
i386 one into x86_64 repo.
Comment 8 Karol Trzcionka 2007-12-06 10:42:49 EST
(In reply to comment #6)
> While playing with version warzone2100-2.0.8-0.1.rc1.fc8 I get the following
error.
> 
> [patoh@asmodeus][~]
> % warzone2100 
> open /dev/[sound/]dsp: Permission denied
> error:      OpenAL Vendor: (null)
> OpenAL Version: (null)
> OpenAL Renderer: (null)
> OpenAL Extensions: (null)
> error:      Couldn't open audio device.
> error:      loadFile2: optional file sequenceaudio/brfcom.txt could not be found!
> error:      loadFile2: optional file sequenceaudio/cam1/cam1ascv.txt could not
> be found!
Another program use /dev/dsp probably it is artsd. Before running warzone2100
please:
killall artsd


(In reply to comment #7)
> Heeeey! Where's x86_64 version??? If there's no such version, at least place
> i386 one into x86_64 repo.
I am not able to do it. You must use warzone2100 form i386 repo :(
Comment 9 Fedora Update System 2007-12-06 17:50:45 EST
warzone2100-2.0.8-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Patrick Ohearn 2007-12-07 00:09:40 EST
(In reply to comment #8)
> (In reply to comment #6)
> > While playing with version warzone2100-2.0.8-0.1.rc1.fc8 I get the following
> error.
> > 
> > [patoh@asmodeus][~]
> > % warzone2100 
> > open /dev/[sound/]dsp: Permission denied
> > error:      OpenAL Vendor: (null)
> > OpenAL Version: (null)
> > OpenAL Renderer: (null)
> > OpenAL Extensions: (null)
> > error:      Couldn't open audio device.
> > error:      loadFile2: optional file sequenceaudio/brfcom.txt could not be
found!
> > error:      loadFile2: optional file sequenceaudio/cam1/cam1ascv.txt could not
> > be found!
> Another program use /dev/dsp probably it is artsd. Before running warzone2100
> please:
> killall artsd
> 
> 
> (In reply to comment #7)
> > Heeeey! Where's x86_64 version??? If there's no such version, at least place
> > i386 one into x86_64 repo.
> I am not able to do it. You must use warzone2100 form i386 repo :(
> 

This is a system wide issue, I have no sound at all, so its not related to
warzone2100 :)

Offtopic, how can I downgrade from updates-testing to updates. I have disabled
the repo's and yum dosn't want to downgrade anything.

Note You need to log in before you can comment on or make changes to this bug.