Bug 30234 - installer hangs with ZeroDivisionError
installer hangs with ZeroDivisionError
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-01 18:41 EST by Michel Spierenburg
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-02 11:30:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Spierenburg 2001-03-01 18:41:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)




Reproducible: Always
Steps to Reproduce:
1. Install Red Hat 7.0 Workstation
2. When installation of packages starts it stops after setup package
3. 
	

Actual Results:  anaconda failed

Expected Results:  install all the packages

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1543, in 
doInstall
    self.instCallback, p)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1306, in 
instCallback
    intf.completePackage(h)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 572, in 
completePackage
    self.timeCompleteW.setText("%12s" % formatTime(elapsedTime))
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 552, in 
formatTime
    amt = amt % (60 * 60)
ZeroDivisionError: float modulo

Local variables in innermost frame:
amt: 4.19616699219e-05
hours: 1.16560194227e-08

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2001-03-02 11:30:17 EST
Please give the steps to reproduce this issue.
Comment 2 Michel Spierenburg 2001-03-03 02:49:43 EST
I did some more tests and found that it fails on different points all the time. 
When documenting all the steps I took a lot longer to go through the install 
process. Due to this it already failed after entering the root pwd. So that 
made me think about the time issue.
It seems that I'm having some kind of processor/mb/RAM problem when the PC 
heats up.

So it's my own problem not an anaconda problem.

Sorry to have bothered you.

Regards,
Michel.

Note You need to log in before you can comment on or make changes to this bug.