Bug 30235 - Korean support for /etc/X11/Xmodmap
Korean support for /etc/X11/Xmodmap
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
http://user.chollian.net/~queenrjh/he...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-01 18:52 EST by Jong-Hoon, Ryu
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-21 16:52:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jong-Hoon, Ryu 2001-03-01 18:52:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)




Reproducible: Always
Steps to Reproduce:

Hello,


I'm a manager at KM4R(Korean Messages for RedHat)..  :)

http://user.chollian.net/~queenrjh/help/sgml


this is very useful for Korean..

We can switch the language (Korean/English/Chinese) During when we using X.

Plz Assign it below contents..


Best Regards,

Ryu.


Have a Good Time~!


=====START============================================================

! /etc/X11/Xmodmap
!
! global Xmodmap file -- used by both xdm and xinit (startx)

! keycode and keysym remapping should generally be used only if the X
! server does not use the XKEYBOARD extension (i.e., there is a uncommented
! line "XkbDisable" in the keyboard section of /etc/X11/XF86Config)

! i386 and alpha
! keycode 22 = BackSpace
! keycode 107 = Delete           

! powerpc
! keycode 59 = BackSpace
! keycode 125 = Delete

! sparc
! keycode 50 = BackSpace
! keycode 73 = Delete

! Euro sign support
! keycode 26 = e E currency
! keycode 54 = c C cent
! keycode 113 = Mode_switch Mode_switch Multi_key

! Korean support
!keycode 121 = Hangul_Hanja
!keycode 122 = Hangul

=====END==============================================================
Comment 1 Mike A. Harris 2002-12-21 16:52:05 EST
I'm not sure if this is something still relevant or not, and I'm unable
to easily tell by investigating the keymaps myself as I don't use international
keyboard features personally.

However, the /etc/X11/Xmodmap file is intended to be blank by default and
customizeable by the system administrator.  If XFree86 does not currently
support what you've suggested above by default out of the box, then it is
something that probably should be suggested directly to XFree86.org so that
they can consider including it in the stock XFree86 sources, and all Korean
users using X may benefit, rather than it being a distribution specific
change.

I'm closing this as WONTFIX for now however as I don't want this to be
a local Red Hat specific change, however you can make your suggestion to 
XFree86.org by mailing it to xpert@xfree86.org mailing list for
discussion, or by sending keymap file patches, or similar to
fixes@xfree86.org.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.