Bug 30248 - weird modversion.h with delted contents in /usr/include/linux
weird modversion.h with delted contents in /usr/include/linux
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-01 21:11 EST by Suhaib Siddiqi
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 21:11:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suhaib Siddiqi 2001-03-01 21:11:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i686)


I was attempting to compile some drivers code on RC1 and it returned
following errors
for #include <linux/modversions.h>.  The /usr/include/linux/modversions.h
file contains only these lines:


#error Modules should never use kernel-headers system headers,
#error but headers from an appropriate kernel-source


I downloaded Kerbel 2.4.2 code from kernel.org and compiled it myself and
it produced
a modversion.h file with proper incldues.

My question?  Has RedHat decided to delete the contents of modversions.h
file and pack it
with kernel RPM?  This is really weird because it breaks a lot of source
code which use
#include <linux/modversions.h>.

Suhaib

Reproducible: Always
Steps to Reproduce:
1.compile nidia kernel driver code
2.
3.
	

Actual Results:  I was attempting to compile some drivers code on RC1 and
it returned following errors
for #include <linux/modversions.h>.  The /usr/include/linux/modversions.h
file contains only these lines:


#error Modules should never use kernel-headers system headers,
#error but headers from an appropriate kernel-source


I downloaded Kerbel 2.4.2 code from kernel.org and compiled it myself and
it produced
a modversion.h file with proper incldues.

My question?  Has RedHat decided to delete the contents of modversions.h
file and pack it
with kernel RPM?  This is really weird because it breaks a lot of source
code which use
#include <linux/modversions.h>.

Suhaib

Expected Results:  the contents of /usr/include/linux/modversions.h should
not be deleted.
End user need it to compile code, or every RedHat Linux end user will end
up installing Kernel sources and recompiling it to generate a proper
modversions file. 

Fix it please!!!!!!!!!!!!!!!!!!!!

You will be breaking millions/zillions and trillions of source code out
there!!!!
Comment 1 Michael K. Johnson 2001-03-01 22:17:31 EST
The Linux industry standard, which Red Hat Linux follows, uses
/lib/modules/`uname -r`/build/include as the include directory
for building modules.

Note You need to log in before you can comment on or make changes to this bug.