Bug 302861 - Missing GLX_EXT_texture_from_pixmap on ati
Missing GLX_EXT_texture_from_pixmap on ati
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-24 05:29 EDT by Shawn Starr
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 18:16:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Starr 2007-09-24 05:29:54 EDT
Description of problem:
Compiz bails with the following errors on my rv350:

compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Version-Release number of selected component (if applicable):
compiz-0.5.2-12.6b86f3.fc8
xorg-x11-drv-ati-6.7.194-1.fc8
Comment 1 Matěj Cepl 2007-09-24 07:11:16 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Shawn Starr 2007-09-24 18:03:25 EDT
I have tried two different methods:

1) First a custom xorg.conf file to enable additional driver features. Attached
as xorg.conf.custom.ati

2) Log file Xorg.0.log.custom.ati 

3) Log file without an xorg.conf file: Xorg.0.log.autodetect
Comment 3 Shawn Starr 2007-09-24 18:16:03 EDT
I will close this. I have compiz working now. I suppose something in today's
rawhide snapshot has fixed this since composite effects now work.

Note You need to log in before you can comment on or make changes to this bug.