Bug 302861 - Missing GLX_EXT_texture_from_pixmap on ati
Summary: Missing GLX_EXT_texture_from_pixmap on ati
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-24 09:29 UTC by Shawn Starr
Modified: 2018-04-11 07:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 22:16:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Shawn Starr 2007-09-24 09:29:54 UTC
Description of problem:
Compiz bails with the following errors on my rv350:

compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Version-Release number of selected component (if applicable):
compiz-0.5.2-12.6b86f3.fc8
xorg-x11-drv-ati-6.7.194-1.fc8

Comment 1 Matěj Cepl 2007-09-24 11:11:16 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.


Comment 2 Shawn Starr 2007-09-24 22:03:25 UTC
I have tried two different methods:

1) First a custom xorg.conf file to enable additional driver features. Attached
as xorg.conf.custom.ati

2) Log file Xorg.0.log.custom.ati 

3) Log file without an xorg.conf file: Xorg.0.log.autodetect

Comment 3 Shawn Starr 2007-09-24 22:16:03 UTC
I will close this. I have compiz working now. I suppose something in today's
rawhide snapshot has fixed this since composite effects now work.



Note You need to log in before you can comment on or make changes to this bug.