Bug 30287 - RH7.0 network boot fails
RH7.0 network boot fails
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-02 01:13 EST by Allen J. Newton
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-17 20:16:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allen J. Newton 2001-03-02 01:13:11 EST
When I boot the bootnet image for RH7.0 on a machine with no CDROM
but with a 3com 509 network card (which works fine) to mount an
NFS mount from a server, I get the error "Doesn't appear to have a
RedHat installation tree".

This procedure worked fine for RH6.0, and I believe also for RH6.2.

Please help, I don't want to have to buy a CDROM for this particular
machine as it would otherwise never need it.

Thank you.
Comment 1 Michael Fulbright 2001-03-02 11:33:46 EST
Did you copy both CD's into the same NFS exported directory? This is now required.
Comment 2 Allen J. Newton 2001-03-02 22:23:49 EST
I didn't know that it was "now required", I guess it always was, but no one
noticed when RH came on just one CD.

After receiving your suggestion, I have done this.  Now I don't get that error,
the installation bombs completely out to a reboot prompt.

The error message is:
Running anaconda - may take some time to load...
'import site' failed; use -v for traceback
Traceback (innermost last):
  File "/usr/bin/anaconda", line 3, in ?
    import sys, os, signal
  File "/usr/lib/python1.5/os.py", line 1
<< a bunch of binary crap here >>
      ^
SyntaxError: invalid syntax
install exited abnormally
sending termination signals...done
unmounting filesystems...
    /mnt/source
    /dev/pts
    /proc
you may safely reboot your system


Any more ideas?  I really don't want to get a CDROM for this system or pull
one out of another intact system even to "borrow" it.

Please help, thanks.
Comment 3 Michael Fulbright 2001-03-06 15:23:30 EST
That looks like a read error occurred when copying the CD's to your NFS exported
directory.
Comment 4 Alexei Nikiforov 2001-03-09 03:00:23 EST
I got the same problem. It seems it depens on nfs server. I can't 
to install from our common server ( BSD propably ) but can from my local
server  (RH-6.1)
Comment 5 Michael Fulbright 2001-03-09 11:24:33 EST
Is the BSD server running NFS 3 or 2?
Comment 6 Allen J. Newton 2001-03-17 20:16:18 EST
I don't remember if the CD's of RH7.0 I had were the respin versions or not, so
I downloaded them again and re-burned them.  Then I installed RH7.0 on the NFS
server from the respin CD's, made a new bootnet.img floppy, and now it works.

For now, I guess I'm going to assume that I got the non-respin versions to begin
with and maybe that's why it didn't work.

Everything's Jake now for me.  Thanks for the advice about both CD's being
copied together to the NFS mounted directory...
Comment 7 Michael Fulbright 2001-04-02 11:59:56 EDT
No problem - we're going to fix the issue of having to copy both CDs when we get
some time.

Note You need to log in before you can comment on or make changes to this bug.