Bug 303 - 5.2 upgrade silently overwrites /etc/shells
5.2 upgrade silently overwrites /etc/shells
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-04 15:34 EST by adam
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-09 16:12:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adam 1998-12-04 15:34:23 EST
upgraded from 5.0 to 5.2, and when I was done, I couldn't
ftp to the box, though I'd been able to before. Turns out my
additions to /etc/shells (for my own login shell) had
disappeared, and /etc/shells had been returned to a
pristine, out of the box state.

Had the process left behind a .rpmsave file, that'd be at
least consistent with the rest of the changes that had
happened -- as it is, though, rpm -qf /etc/shells disavows
any knowledge of the file.  Oops.  Some upgrade script isn't
checking to make sure things haven't changed...
Comment 1 Jay Turner 1998-12-08 15:51:59 EST
I installed RH5.0, added a last line to /etc/shells of /bin/zsh.  I
upgraded from 5.0 to 5.2, and observed the /etc/shells was identical
to the one I had made in RH5.0.  Sorry, couldn't duplicate the
problem.
Comment 2 Jay Turner 1998-12-09 16:12:59 EST
*** This bug has been marked as a duplicate of 365 ***

Note You need to log in before you can comment on or make changes to this bug.