This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 303191 - php preg_match functionality broken
php preg_match functionality broken
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: php (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-24 10:44 EDT by Chuck Mead
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 09:28:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chuck Mead 2007-09-24 10:44:20 EDT
Description of problem:
RHEL4 php is being built with the in-system pcre-regex ala 
--with-pcre-regex=/usr. This breaks preg_match functionality. This appears to
have been happening for a while as the PHP guys keep getting recurring tickets.
See PHP bug:

http://bugs.php.net/bug.php?id=31501&edit=1

Version-Release number of selected component (if applicable):
php-4.3.9-3.22.5.x86_64

How reproducible:
run phpinfo() to see the build.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Joe Orton 2007-09-25 03:50:49 EDT
Thanks for the report.  Can you give an example of a failing preg_match() call?
 The example used in the referenced upstream bug report seems to work fine with
the RHEL4 php.
Comment 2 Chuck Mead 2007-09-25 09:28:21 EDT
Uhm... Bloomberg is not runing our apache and as it happens that is where the
bug lies! Withdrawn... NOT A BUG.

Note You need to log in before you can comment on or make changes to this bug.