This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 30348 - RFE: Beta program CD generation program - ISO size limits
RFE: Beta program CD generation program - ISO size limits
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-02 13:19 EST by R P Herrold
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-09 11:24:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2001-03-02 13:19:32 EST
This is filed against anaconda, although as I recall, only the pseudo-code describing the package division process on Beta program (and 
indeed, final "pressed") CD's has been discussed.  This is a new problem, as the move to multiple CD install sets has occurred.

Problem statement:  

CDR media have had read-error problems.  Some of this seems due to media type -- other errors are due to the increasing capacity of CD 
media not being supported by older CD drives.  Beta testers use a variety of hardware, and not just the 'latest and greatest' which may be able 
to read larger physical media formats.  All CD's can read the interior tracks, but tend to fail at the exterior rings .

Proposed solution:

1. Automate formal balancing of package and related content into ISO image sizes of nearly equal disk sizes -- 

2. Limit .ISO size to a value determined after formal testing with older 2x IDE, SCSI, and non-IDE Mitsumi, Sony CDU-31A's, and 2x 
SoundBlaster CD drives (i.e., the roughly 650M image limit) .

======================================

From an email to brogan@redhat.com

1.  At Design inception -- design the bug out

  ( use only the interior 640 [or whatever] M _out_, on a CD
[Especially on CDR media] to enhance support for older
drives -- I filed this against anaconda, although I realize
that it is not a formal Anaconda function -- it probably needs
to be aded to the sme package which holds genhdlist
(anaconda-tools<?>)

-- That is, when multiple CD's are shipped, roughly equalize
image size -- there should be two 664 +/- the smallest RPM  
image variance -- This was discussed on the list, but not   
then bugzillaed by me -- 

-- That is, when multiple CD's are shipped, roughly equalize
image size -- there should be two 664 +/- the smallest RPM
image variance -- This was discussed on the list, but not
bugzillaed by me -- I have bugzillaed as


-r--r--r--    1 root     root          295 Feb 18 16:13  MD5SUMS
-r--r--r--    1 root     root     630892544 Feb 18 15:20  wolverine-docs.iso
-r--r--r--    1 root     root     678203392 Feb 18 01:35  wolverine-i386-disc1-$
-r--r--r--    1 root     root     650846208 Feb 18 03:32  wolverine-i386-disc2.$

These should be two 664 M images -- and indeed
(unfortunately) may need to break to 3 CD's --) but recall --
the SRPMS were added to the end of the second image, so there
is probably room to keep it under 650M

-- Russ Herrold
Comment 1 Preston Brown 2001-03-10 01:42:02 EST
we will insure that the CDs are under the proper ISO file size limit for our
final set.

Note You need to log in before you can comment on or make changes to this bug.