Bug 30368 - bugs introduced in LPRng-3.7.4-17 (post Wolverine)
Summary: bugs introduced in LPRng-3.7.4-17 (post Wolverine)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: LPRng   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 30369 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-02 20:18 UTC by Joshua Buysse
Modified: 2015-03-05 01:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-07 17:34:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Buysse 2001-03-02 20:18:10 UTC
Under Wolverine's LPRng-3.7.4-16, lpr -P<badprintername> /etc/resolv.conf
returns an error, as it should.  In the patches by crutcher@redhat.com,
something changed in 3.7.4-17 that causes this to hang, never giving an
error and apparently sitting in a loop.  

Strace of lpr in -17:
getsockopt(3, SOL_SOCKET, SO_LINGER, [0], [8]) = 0
setsockopt(3, SOL_SOCKET, SO_LINGER, [1], 8) = 0
rt_sigprocmask(SIG_BLOCK, NULL, [], 8)  = 0
alarm(0)                                = 0
rt_sigaction(SIGALRM, {SIG_IGN}, {SIG_IGN}, 8) = 0
rt_sigprocmask(SIG_UNBLOCK, [ALRM], [], 8) = 0
rt_sigaction(SIGALRM, {0x8050ab4, [], SA_INTERRUPT|0x4000000}, {SIG_IGN},
8) = 0
alarm(6000)                             = 0
write(3, "\2scribble\n", 10)            = 10
rt_sigaction(SIGALRM, {SIG_IGN}, {0x8050ab4, [], SA_INTERRUPT|0x4000000},
8) = 0
alarm(0)                                = 6000
rt_sigprocmask(SIG_BLOCK, NULL, [], 8)  = 0
alarm(0)                                = 0
rt_sigaction(SIGALRM, {SIG_IGN}, {SIG_IGN}, 8) = 0
rt_sigprocmask(SIG_UNBLOCK, [ALRM], [], 8) = 0
rt_sigaction(SIGALRM, {0x8050ab4, [], SA_INTERRUPT|0x4000000}, {SIG_IGN},
8) = 0
alarm(6000)                             = 0
read(3, "\3", 1)                        = 1
rt_sigaction(SIGALRM, {SIG_IGN}, {0x8050ab4, [], SA_INTERRUPT|0x4000000},
8) = 0
alarm(0)                                = 6000
read(3, "spool queue for \'scribble\' does "..., 511) = 132
read(3, 


At this point, it hangs forever.

Comment 1 Joshua Buysse 2001-03-02 20:21:23 UTC
*** Bug 30369 has been marked as a duplicate of this bug. ***

Comment 2 Glen Foster 2001-03-05 20:45:18 UTC
This defect considered a show-stopper (MUST-FIX) for Florence GOLD release

Comment 3 Phil Knirsch 2001-03-07 17:34:36 UTC
OK, tracked down the bug and found the problem. There are two sides where it can
be fixed and we'll probably do it on the lpd side.

Should be in rawhide real soon now... ;)

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.