Bug 30371 - Token Ring adapter does not associate with olympic driver
Token Ring adapter does not associate with olympic driver
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-02 15:41 EST by Ryan D. Anderson
Modified: 2014-03-16 22:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-07 02:05:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan D. Anderson 2001-03-02 15:41:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


After a clean insatll of v7.1, with the Token Ring card present in system, 
the olympic driver/module loads but does is not associated with the 
install PCI adapter.  Card will not insert itself into the network ring.  

Reproducible: Always
Steps to Reproduce:
1.Install RedHat 7.1, (kernel 2.4.1-0.1.9/kernel 2.4.2-0.1.16)
2.Bring system up and configure interface the token ring interface (tr0)
3.issue 'lsmod' command. Look at 'Used' (will read 0)
4.Issue 'ifup tr0'/'ifdown tr0' commands. System will hang
5.After attempting the above, issue 'init 6' command.  System will fail to 
shut down properly
	

Actual Results:  When attempting to manually load the driver ('insmod 
olympic') the system hangs and user must break out of the command ('ctrl-
c').
'lsmod' shows olympic driver loaded but no instances in use.

 When attempting to issue network interface command (i.e. 'ifup tr0') the 
system hangs and user must break out.  The following output is reported by 
the system:

kernel: tr0: SRB timed out.
kernel: SISR=20 MISR=8800
kernel: Unable to handle kernel NULL pointer dereference at virtual 
address 0000006c
kernel:  printing eip:
kernel: c88d4b9d
kernel: *pde = 00000000 
kernel: Oops: 0000
kernel: CPU:    0
kernel: EIP:    0010:[<c88d4b9d>]
kernel: EFLAGS: 00010202
kernel: eax: 00000001   ebx: 0000000f   ecx: c340a000   edx: 00000000   
kernel: esi: c7a8a800   edi: c88d9c00   ebp: 00000216   esp: c21f3ee8   
kernel: ds: 0018   es: 0018   ss: 0018 
kernel: Process ifconfig (pid: 9943, stackpage=c21f3000)
kernel: Stack: c025c900 c01c6d20 c29e9c00 c29e9c00 c29e9c00 00001003 
00001042 00000000 
kernel:        c01bfee7 c29e9c00 c29e9c00 c01c0c7f c29e9c00 c1f2a1e0 
c21f3f5c c29e9c00 
kernel:        bffff908 c01e5b34 c29e9c00 00001042 c21f3f58 00000000 
00000000 c29e9c00 
kernel: Call Trace: [dev_deactivate+48/96] [dev_close+55/112] 
[dev_change_flags+79/272] [devinet_ioctl+708/1584] [sock_ioctl+30/48] 
[sys_ioctl+487/512] [system_call+51/56] 
kernel: Call Trace: [<c01c6d20>] [<c01bfee7>] [<c01c0c7f>] [<c01e5b34>] 
[<c01bb75e>] [<c0141237>] [<c0109007>] 
kernel: 
kernel: Code: 8b 42 6c 48 74 0a ff 4a 6c 0f 94 c0 84 c0 74 07 52 e8 fd 93  

Expected Results:  When issuing the 'insmod olympic' and 'lsmod' commands 
the system should show the olympic driver loaded with 1 instance in use

After issuing 'ifup tr0' system should bring interface up and the adapter 
should insert itself into the network ring.


This problem has been reproduced with both the 2.4.1-0.1.9 and 
2.4.2-0.1.16 kernel versions.  After removing the card from the system by 
using kudzu, then manually configuring the card, the configuration was 
correct and the adapter did insert itself into two seperate lan segments.  
However, this was only produced ONCE (1x).  Upon rebooting the system, 
kudzu detected the card and attempted to configure it for the system, this 
then resulted in another failure.
Comment 1 Arjan van de Ven 2001-03-05 07:56:25 EST
Could you run the oops through ksymoops ?

(for example by trying "dmesg | ksymoops" after it just happended ?)
Comment 2 Matthew Stokes 2001-03-16 13:46:28 EST
Same situation with the 2.4.2-  except no kernel information gets put in 
the /var/log/messages or /var/log/dmesg.  

I also tried rebooting without Kudzu enabled and had the same problem. 

Here's the output from ksymoops with the 2.4.1-0.1.9 kernel:

Warning (compare_maps): ksyms_base symbol __VERSIONED_SYMBOL(shmem_file_setup) 
not found in System.map.  Ignoring ksyms_base entry
Warning (compare_maps): mismatch on symbol partition_name  , ksyms_base says 
c01b0600, System.map says c01524a0.  Ignoring ksyms_base entry
  Receiver lock-up bug exists -- enabling work-around.
Unable to handle kernel NULL pointer dereference at virtual address 0000006c
d089fb9d
*pde = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[<d089fb9d>]
Using defaults from ksymoops -t elf32-i386 -a i386
EFLAGS: 00010202
eax: 00000001   ebx: 0000000f   ecx: cfcee000   edx: 00000000
esi: c57ac800   edi: d08a4700   ebp: 00000216   esp: c577fee8
ds: 0018   es: 0018   ss: 0018
Process ifconfig (pid: 1031, stackpage=c577f000)
Stack: c025c900 c01c6d20 c7ce5e00 c7ce5e00 c7ce5e00 00001003 00001042 00000000 
       c01bfee7 c7ce5e00 c7ce5e00 c01c0c7f c7ce5e00 c67c51e0 c577ff5c c7ce5e00 
       bffff848 c01e5b34 c7ce5e00 00001042 c577ff58 00000000 00000000 c7ce5e00 
Call Trace: [<c01c6d20>] [<c01bfee7>] [<c01c0c7f>] [<c01e5b34>] [<c01bb75e>] 
[<c0141237>] [<c0109007>] 
Code: 8b 42 6c 48 74 0a ff 4a 6c 0f 94 c0 84 c0 74 07 52 e8 fd e3 

>>EIP; d089fb9d <[olympic]olympic_close+15d/220>   <=====
Trace; c01c6d20 <dev_deactivate+30/60>
Trace; c01bfee7 <dev_close+37/70>
Trace; c01c0c7f <dev_change_flags+4f/110>
Trace; c01e5b34 <devinet_ioctl+2c4/630>
Trace; c01bb75e <sock_ioctl+1e/30>
Trace; c0141237 <sys_ioctl+1e7/200>
Trace; c0109007 <system_call+33/38>
Code;  d089fb9d <[olympic]olympic_close+15d/220>
00000000 <_EIP>:
Code;  d089fb9d <[olympic]olympic_close+15d/220>   <=====
   0:   8b 42 6c                  mov    0x6c(%edx),%eax   <=====
Code;  d089fba0 <[olympic]olympic_close+160/220>
   3:   48                        dec    %eax
Code;  d089fba1 <[olympic]olympic_close+161/220>
   4:   74 0a                     je     10 <_EIP+0x10> d089fbad <[olympic]
olympic_close+16d/220>
Code;  d089fba3 <[olympic]olympic_close+163/220>
   6:   ff 4a 6c                  decl   0x6c(%edx)
Code;  d089fba6 <[olympic]olympic_close+166/220>
   9:   0f 94 c0                  sete   %al
Code;  d089fba9 <[olympic]olympic_close+169/220>
   c:   84 c0                     test   %al,%al
Code;  d089fbab <[olympic]olympic_close+16b/220>
   e:   74 07                     je     17 <_EIP+0x17> d089fbb4 <[olympic]
olympic_close+174/220>
Code;  d089fbad <[olympic]olympic_close+16d/220>
  10:   52                        push   %edx
Code;  d089fbae <[olympic]olympic_close+16e/220>
  11:   e8 fd e3 00 00            call   e413 <_EIP+0xe413> d08adfb0 
<END_OF_CODE+bd9a/????>


3 warnings issued.  Results may not be reliable.


Here's the actuall kernel message on mine:

Olympic.c v0.5.0 3/10/00 - Peter De Schrijver & Mike Phillips 
tr0: IBM 16/4 Token ring UTP/STP controller. I/O at 7400, MMIO at d08a4700, LAP 
at d08a6800, using irq 9
PCI: Found IRQ 9 for device 00:10.0
Olympic: 1 IBM PCI Token Ring card(s) found in system.
usb.c: USB disconnect on device 1
usb.c: USB bus 1 deregistered
usb.c: deregistering driver usbdevfs
usb.c: deregistering driver hub
tr0: SRB timed out.
SISR=20 MISR=8000
Unable to handle kernel NULL pointer dereference at virtual address 0000006c
 printing eip:
d089fb9d
*pde = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[<d089fb9d>]
EFLAGS: 00010202
eax: 00000001   ebx: 0000000f   ecx: cfcee000   edx: 00000000
esi: c57ac800   edi: d08a4700   ebp: 00000216   esp: c577fee8
ds: 0018   es: 0018   ss: 0018
Process ifconfig (pid: 1031, stackpage=c577f000)
Stack: c025c900 c01c6d20 c7ce5e00 c7ce5e00 c7ce5e00 00001003 00001042 00000000 
       c01bfee7 c7ce5e00 c7ce5e00 c01c0c7f c7ce5e00 c67c51e0 c577ff5c c7ce5e00 
       bffff848 c01e5b34 c7ce5e00 00001042 c577ff58 00000000 00000000 c7ce5e00 
Call Trace: [<c01c6d20>] [<c01bfee7>] [<c01c0c7f>] [<c01e5b34>] [<c01bb75e>] 
[<c0141237>] [<c0109007>] 

Code: 8b 42 6c 48 74 0a ff 4a 6c 0f 94 c0 84 c0 74 07 52 e8 fd e3 


Hope this helps..
Comment 3 Wendy Hung 2001-03-19 14:36:59 EST
Dennis Jurgensen of the IBM Netfinity Clustering team has reported that this has been fixed in the 2.4.2-0.1.19 kernel.
Comment 4 Arjan van de Ven 2001-03-19 14:43:53 EST
I will close this bug as fixed. If the problem was not fixed after all, or if
it regresses, please reopen this bug.
Comment 5 Matthew Stokes 2001-03-19 23:31:32 EST
Nope, still exists on 2.4.2-0.1.25 kernel.  Except that no kernel message is 
shown.  The ifup command just hangs and when rebooting the system hangs when 
trying to bring down the hung interface.  Let me know if there is any other 
details/testing I can do.
Comment 6 Wendy Hung 2001-03-29 17:13:19 EST
Here is what was found when attempting to install on a system with IBM PCI Token Ring adapter.

Sequence of events:
1. boot installation diskette
2. QA0327.2 CD1in cdrom drive
3. text mode install
4. installation stops when it reaches "going to insmod olympic.o (path is null)"
    system is not in a hang condition, it just stops (mouse and keyboard are still active)

This same hardware was used for a successful install of RC2.

NIC is IBM PCI 16/4 Token Ring adapter - FRU 86H1896
System is IBM 6591(PC300GL)
1 IDE cdrom drive
2 IDE hard drives
Comment 7 Matthew Stokes 2001-03-30 17:27:09 EST
Reinstalled RC2 on Installation on IBM Intellistation EPro with IBM PCI 
Tokenring Adapter (FRU 41H8874).  Installation fro CDROM works fine.  ifup tr0 
succeeds but am unable to ping anything eventhough ifconfig shows correct 
values and route does also.  With kernel 2.4.2-0.1.19 Olympic module will 
associate with card but will not insert into ring, nor does the MAU show 
connection to the machine.  IE the machine thinks it is network but can't get 
onto the net.

Will try updating to latest fixes/kernel from up2date..
Comment 8 Arjan van de Ven 2001-04-07 16:56:43 EDT
We've update the tokenring drivers in 2.4.2-0.1.52. Please recheck this issue
and add information to this bugreport once this or a new kernel makes it into
RawHide.
Comment 9 Wendy Hung 2001-04-13 11:11:42 EDT
Token-ring is functional with RH7.1 Gold.
The installation does not autodetect the card as it did in RC2.
Use netconfig tool to configure tr0.
Comment 10 Arjan van de Ven 2001-04-13 15:19:45 EDT
Assigning to anaconda for the installer part...
Comment 11 Brent Fox 2001-04-13 17:06:55 EDT
This is really more of a kudzu issue than an installer issue.  It looks like the
card has an entry in the kudzu pci table:
0x1014  0x003e  "olympic"       "IBM|16/4 Token ring UTP/STP controller"

It looks like this should work, but the card in question could have different
pci ids.  Can you post the output of '/sbin/lspci -n' and '/sbin/lspci -v'?

Changing component to kudzu.
Comment 12 Bill Nottingham 2002-11-25 16:58:21 EST
closing, no response

Note You need to log in before you can comment on or make changes to this bug.