Bug 30374 - Kernel Compile of 2.4.1-0.1.14 fails out of the box
Kernel Compile of 2.4.1-0.1.14 fails out of the box
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
: 29667 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-02 16:06 EST by J. Alexander Jacocks
Modified: 2008-08-01 12:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-09 11:38:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pcmcia build failure trace (3.54 KB, text/plain)
2001-03-09 10:28 EST, R P Herrold
no flags Details

  None (edit)
Description J. Alexander Jacocks 2001-03-02 16:06:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.14 i686)


System: Asus A7V Thunderbird 900 384mb/1gb swap Promise ATA/100
The kernel fails to compile using both the Athlon (non-smp) and default
configs.  Downloding kernel-2.4.2 source and using the athlon config works.

The kernel fails on compiling main.c with the following: (long)
gcc -D__KERNEL__ -I/usr/src/linux-2.4/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -pipe
-mpreferred-stack-boundary=2 -march=athlon    -c -o init/main.o init/main.c
In file included from /usr/src/linux-2.4/include/linux/irq.h:57,
                 from /usr/src/linux-2.4/include/asm/hardirq.h:6,
                 from /usr/src/linux-2.4/include/linux/interrupt.h:45,
                 from /usr/src/linux-2.4/include/asm/string.h:296,
                 from /usr/src/linux-2.4/include/linux/string.h:27,
                 from /usr/src/linux-2.4/include/linux/fs.h:23,
                 from /usr/src/linux-2.4/include/linux/capability.h:17,
                 from /usr/src/linux-2.4/include/linux/binfmts.h:5,
                 from /usr/src/linux-2.4/include/linux/sched.h:9,
                 from /usr/src/linux-2.4/include/linux/mm.h:4,
                 from /usr/src/linux-2.4/include/linux/slab.h:14,
                 from /usr/src/linux-2.4/include/linux/proc_fs.h:5,
                 from init/main.c:15:
/usr/src/linux-2.4/include/asm/hw_irq.h: In function `x86_do_profile':
/usr/src/linux-2.4/include/asm/hw_irq.h:200: `prof_pid' undeclared (first
use in this function)
/usr/src/linux-2.4/include/asm/hw_irq.h:200: (Each undeclared identifier is
reported only once
/usr/src/linux-2.4/include/asm/hw_irq.h:200: for each function it appears
in.)
/usr/src/linux-2.4/include/asm/hw_irq.h:200: `current' undeclared (first
use in this function)
In file included from /usr/src/linux-2.4/include/linux/mm.h:4,
                 from /usr/src/linux-2.4/include/linux/slab.h:14,
                 from /usr/src/linux-2.4/include/linux/proc_fs.h:5,
                 from init/main.c:15:
/usr/src/linux-2.4/include/linux/sched.h: At top level:
/usr/src/linux-2.4/include/linux/sched.h:550: `prof_pid' used prior to
declaration
make: *** [init/main.o] Error 1

Reproducible: Always
Steps to Reproduce:
1.install kernel 2.4.1-0.1.14
2.make dep;make clean;make bzImage
3.boom
	

Actual Results:  gcc -D__KERNEL__ -I/usr/src/linux-2.4/include -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe
-mpreferred-stack-boundary=2 -march=athlon    -c -o init/main.o init/main.c
In file included from /usr/src/linux-2.4/include/linux/irq.h:57,
                 from /usr/src/linux-2.4/include/asm/hardirq.h:6,
                 from /usr/src/linux-2.4/include/linux/interrupt.h:45,
                 from /usr/src/linux-2.4/include/asm/string.h:296,
                 from /usr/src/linux-2.4/include/linux/string.h:27,
                 from /usr/src/linux-2.4/include/linux/fs.h:23,
                 from /usr/src/linux-2.4/include/linux/capability.h:17,
                 from /usr/src/linux-2.4/include/linux/binfmts.h:5,
                 from /usr/src/linux-2.4/include/linux/sched.h:9,
                 from /usr/src/linux-2.4/include/linux/mm.h:4,
                 from /usr/src/linux-2.4/include/linux/slab.h:14,
                 from /usr/src/linux-2.4/include/linux/proc_fs.h:5,
                 from init/main.c:15:
/usr/src/linux-2.4/include/asm/hw_irq.h: In function `x86_do_profile':
/usr/src/linux-2.4/include/asm/hw_irq.h:200: `prof_pid' undeclared (first
use in this function)
/usr/src/linux-2.4/include/asm/hw_irq.h:200: (Each undeclared identifier is
reported only once
/usr/src/linux-2.4/include/asm/hw_irq.h:200: for each function it appears
in.)
/usr/src/linux-2.4/include/asm/hw_irq.h:200: `current' undeclared (first
use in this function)
In file included from /usr/src/linux-2.4/include/linux/mm.h:4,
                 from /usr/src/linux-2.4/include/linux/slab.h:14,
                 from /usr/src/linux-2.4/include/linux/proc_fs.h:5,
                 from init/main.c:15:
/usr/src/linux-2.4/include/linux/sched.h: At top level:
/usr/src/linux-2.4/include/linux/sched.h:550: `prof_pid' used prior to
declaration
make: *** [init/main.o] Error 1

Expected Results:  Compiled kernel
Comment 1 Arjan van de Ven 2001-03-05 07:57:03 EST
investigating
Comment 2 Need Real Name 2001-03-08 19:25:41 EST
I have this problem when I set the processor option to Athlon.  See the kernel
mailing lists for a resolution to this problem, for instance
  http://www.uwsg.iu.edu/hypermail/linux/kernel/0101.2/0273.html
(I found it by searching google with "kernel 2.4.1 athlon").

It appears that your kernel 2.4.2 package in the latest rawhide has the same
annoying problem.

-Paul Komarek
Comment 3 R P Herrold 2001-03-09 10:27:14 EST
I receive a similar build error out in my build with 7.1RC2 stock kernel sources
... I will attach a trace in a moment
Comment 4 R P Herrold 2001-03-09 10:28:45 EST
Created attachment 12175 [details]
pcmcia build failure trace
Comment 5 Arjan van de Ven 2001-03-09 11:13:48 EST
herrold@owlriver.com: that is caused by not doing make mrproper before
changing from UP/SMP to SMP/UP
Comment 6 Bill Nottingham 2001-03-09 11:38:47 EST
*** Bug 29667 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2001-03-09 11:46:04 EST
Just tried with 2.4.2-0.1.23, and the athlon config; it builds OK.

Comment 8 R P Herrold 2001-03-09 21:28:30 EST
I may have contributed to a false Status resolved, with NO Resolution -- to the
initial issues...  I think this is not closed ...

Note You need to log in before you can comment on or make changes to this bug.