Bug 304071 - milter-regex 1.7 fails if there are more than 507 lines in milter-regex.conf
milter-regex 1.7 fails if there are more than 507 lines in milter-regex.conf
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: milter-regex (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-24 17:05 EDT by Eli Wapniarski
Modified: 2008-03-08 03:57 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.7-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 13:22:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eli Wapniarski 2007-09-24 17:05:28 EDT
Description of problem:

After adding more than 507 lines milter-regex fails with the following 
message.

milter-regex[2935]: parse_ruleset: /etc/mail/milter-regex.conf:507: yacc stack 
overflow
milter-regex[2935]: cb_connect: get_ruleset

Version-Release number of selected component (if applicable):

milter-regex-1.7-1.fc7

How reproducible:

Always

Additional info:

I worked the problem with Daniel Hartmeier, the developer of milter-regex. He 
suggested that a change be made to a line in Makefile.linux:

CFLAGS=         -g

to

CFLAGS=         -g -DYYMAXDEPTH=8192


then run the following:

make -f Makefile.linux clean
make -f Makefile.linux

I modified the file contained in the packaged tar.gz file but that did not 
help.

What I wound up doing was modifying the SPEC file from:

%build
%{__make} %{?_smp_mflags} -f Makefile.linux CFLAGS="%{optflags}"

to

%build
%{__make} %{?_smp_mflags} -f Makefile.linux clean
%{__make} %{?_smp_mflags} -f Makefile.linux 
CFLAGS="%{optflags} -DYYMAXDEPTH=8192"

This fixed the problem. Could you please provide a fixed package? Thanks.
Comment 1 Fedora Update System 2008-02-18 12:47:29 EST
milter-regex-1.7-3.fc8 has been submitted as an update for Fedora 8
Comment 2 Fedora Update System 2008-02-18 12:48:32 EST
milter-regex-1.7-3.fc7 has been submitted as an update for Fedora 7
Comment 3 Paul Howarth 2008-02-18 13:04:20 EST
The "make clean" step isn't actually necessary for an RPM build since the whole
package build takes place in a "clean" environment. I've finally gotten round to
reproducing this bug and testing the fix today, and an update should appear in
updates-testing soon.

I'm a little surprised that there hasn't been an update from upstream in all
this time, though maybe he's been as busy as I have ;-)
Comment 4 Eli Wapniarski 2008-02-18 14:17:32 EST
I'm glad to see that this has finally gone upstream. I will be happy to see 
this update.
Comment 5 Fedora Update System 2008-02-18 22:13:05 EST
milter-regex-1.7-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update milter-regex'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1768
Comment 6 Fedora Update System 2008-03-03 13:22:50 EST
milter-regex-1.7-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-03-03 13:25:12 EST
milter-regex-1.7-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Eli Wapniarski 2008-03-08 03:57:32 EST
Finally had the time to install the new package. It seems to be working.

Thank you very much

Note You need to log in before you can comment on or make changes to this bug.